centrprof20
?>

Решить тест по ! 100 1. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =10; for i: =1 to 3 do begina: =a-2end; 2. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =10; for i: =0 to 4 do begina: =a-iend; 3. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =2; for i: =0 to 3 do begina: =a+iend; 4. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =4; for i: =1 to 2 do begina: =a+aend; 5. какое число будет выведено на экран после выполнения этого фрагмента программы? for i: =2 downto 1 dowrite(i); 6. какое число будет выведено на экран после выполнения этого фрагмента программы? write(4); for i: =4 downto 3 dowrite(2*i); 7. какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i: =3 to 5 dowrite(i); ​​

Информатика

Ответы

sanhimki47
1.

a = 4

                  2.

a = 0

                  3.

a = 8

                  4.

a = 16

                  5.

вывод: 21

                  6.

вывод: 486

                  7.

вывод: 1345

andreevaanastsiyao82
R: =sqr(sqr(sqr(sqr(sqr(x))*x)*x))*x; // 45 r: =sqr(sqr(sqr(sqr(x))*x))*x; // 21 r: =sqr(sqr(sqr(sqr(*x; // 17 r: =sqr(sqr(sqr(x))*x)*x; // 11 пример полной программы, реализующей такой алгоритм // pascalabc.net 3.3, сборка 1611 от 06.01.2018 // внимание! если программа не работает, обновите версию! function dec2bin(x: integer): string; begin   var t: =x;   var r: string: ='';   while t> =2 do (r,t): =(t mod 2+r,t shr 1);   result: =t+r end; function pow(x: real; n: integer): real; // быстрое возведение в степень "слева направо" begin   var m: =dec2bin(n);   result: =x;   for var i: =2 to m.length do begin       result: =sqr(result);       if m[i]='1' then result*=x       end end; begin   var x: =readreal('укажите основание х: ');   var n: =readinteger('укажите степень n: ');   writeln(x,'^',n,' = ',pow(x,n)) end. примеры укажите основание х: 0.918 укажите степень n: 39 0.918^39 = 0.0355520433528712 укажите основание х: -2 укажите степень n: 15 -2^15 = -32768 укажите основание х: 12.6 укажите степень n: 23 12.6^23 = 2.03480378921486e+25
Mariya Filippov

ответ:

публичное облако – это бизнес-модель предоставления услуг, при которой все ресурсы дата-центра, такие как вычислительные мощности, диски и сети, объединяются в большие пулы виртуальных ресурсов, в дальнейшем части этих ресурсов предоставляются в виде «сборных» vцодов, которые выделяются для арендаторов (tenants). даже пользователи с невысокой it-квалификацией способны выделенной им из общего пула частью it-инфраструктуры с панели самообслуживания. по мере необходимости арендатор iaas может создавать дополнительные виртуальные машины, удалять существующие, настраивать изолированные и маршрутизируемые сети и многое другое.

виртуальные машины разных арендаторов изолированы друг от друга, поэтому не стоит понимать публичность такого облака как отсутствие защищенности ваших данных. публичность облака означает, что ваши данные могут храниться на одном сервере с данными других компаний, но доступа к вашим данным при этом у них нет. нельзя однозначно сказать на каком именно оборудовании будут находится ваши виртуальные машины, так как при хранении в кластере виртуальные машины перемещаются между серверами для нагрузки и повышения отказоустойчивости. именно выделение «частных» ресурсов из общего «публичного» пула делает облако публичным, но данные пользователей при этом находятся под защитой современных организационно-технических средств и решений.гибридное облако – это модель потребления it-ресурсов, при которой организация часть системы размещается в публичном "облаке", на базе оборудования облачного провайдера, а часть – в приватном "облаке", на серверах, принадлежащих самой компании или взятых в аренду целиком. концепция гибридного "облака" (hybrid cloud) позволяет объединить в единое облачное пространство внутреннее (onsite) корпоративное облако и внешнее (offsite) облако сервис-провайдера. основная идея "гибридного облака" заключается в том, что, когда собственных мощностей не хватает, можно воспользоваться внешними ресурсами. гибридные облака используются как возможность выхода за пределы облачных мощностей компании в случае пиковых нагрузок или с целью отказа от капитальных затрат в пользу операционных расходов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить тест по ! 100 1. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =10; for i: =1 to 3 do begina: =a-2end; 2. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =10; for i: =0 to 4 do begina: =a-iend; 3. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =2; for i: =0 to 3 do begina: =a+iend; 4. чему будет равно значение целой переменной «a» после выполнения этого фрагмента программы? a: =4; for i: =1 to 2 do begina: =a+aend; 5. какое число будет выведено на экран после выполнения этого фрагмента программы? for i: =2 downto 1 dowrite(i); 6. какое число будет выведено на экран после выполнения этого фрагмента программы? write(4); for i: =4 downto 3 dowrite(2*i); 7. какое число будет выведено на экран после выполнения этого фрагмента программы? write(1); for i: =3 to 5 dowrite(i); ​​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kalina1372
Avdeeva Inga1505
arevik2307
format-l3364
Мартынова1638
yfetyukov
vbnm100584
Barabanov Gerasimenko
Элизбарян
Ingakazakova
Мануэлла
Алина1564
magazin-71
Adno1578
kraevaea
▲