beliaeva2
?>

Решить : найти произведение чисел от 0, 5 до 5 для цикла с постусловием(шаг-05) напишите программу

Информатика

Ответы

marim1994361
Program abc; var  a, b, c, d, h, s, p: real; begin    writeln('введите 3 стороны треугольника');     readln(a);     readln(b);     readln(c);     if c > a + b then writeln('ошибка! одна сторона не может быть больше суммы двух других, введите третью сторону ещё раз или перезапустите программу и введите верные данные'); if c > a + b then readln(c); if (a > b) and (a > c) then d : = a  else if (b > c) then d : = b else d : = c; p : = (a + b + c) / 2; s : = sqrt(p * (p - a) * (p - b) * (p - c)); h : = 2 * s / d; writeln('высота равна -  '+h); end.
juliajd
Var a, b, c, max, p, h : real; begin write('введите сторону а'); readln (a); write('введите сторону b'); readln (b); write('введите сторону c'); readln (c); while ((c > a+b) or (a> b+c) or (b> a+c)) begin write ('введите повторно сторону с'); readln (c); end; if (a> =b) and (a> =c) then max: =a else if (b> =a) and (b> =c) then max: =b else if if (c> =b) and (c> =a) then max: =c; p: =(a+b+c)/2 h: = 2*sqrt (p*(p-a)*(p-b)*(p-c))/max; writeln ('h= ',h); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить : найти произведение чисел от 0, 5 до 5 для цикла с постусловием(шаг-05) напишите программу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

saniopt
kmb1960679
Максим Павел
vsnimschikov391
ak74-81
Zimin1111
Валуева
euzdenova
Alekseevich_Elena
Valerevna-Vardan
argent
Panfilov_Anna
koldunovan
av4738046
olechka197835
▲