Спивак
?>

Даны три натуральных числа. напишите программу, определяющую, существует ли треугольник с такими длинами сторон. если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний) в python, )

Информатика

Ответы

Кольцова
Попробуй  program pascalguru;   var s: string;     f,t: text; function preobr(s: string): string; var i,j,p,n,sered: integer;     gl,zp,slovo: string;     m: array [1..80] of string; beginzp: ='! ? *,.';   gl: ='аоуыэяеёюи';     p: =pos(' ',s);   i: =0;         repeat        inc(i);         slovo: =copy(s,1,p-1);         m[i]: =slovo;         delete(s,1,p);         p: =pos(' ',s);         until p=0;         n: =i+1;         m[n]: =s;       for i: =1 to n do      begin    s: =m[i];         if pos(s[length(s)],zp)< > 0 then p: =length(s)-1 else p: =length(s);       sered: =(p div 2)+1;     if (not odd(p)) or (p< 3) then continue;       if pos(s[1],gl)=0       then continue;       if pos(s[sered],gl)=0   then continue;       if pos(s[p],gl)=0       then continue;         s[1]: =upcase(s[1]);     s[sered]: =upcase(s[sered]);     s[p]: =upcase(s[p]);       m[i]: =s+'('+s[1]+','+s[sered]+','+s[p]+')';       end;             s: ='';       for i: =1 to n do s: =s+m[i]+' ';   preobr: =s; end;   beginassign(f,'input.txt'); reset(f); assign(t,'output.txt'); rewrite(t);   while not eof(f) do      begin      readln(f,s);       writeln(t, preobr(s) );       end;     writeln('файл успешно ');   close(f); close(t); readln; end.
kapustina198690
А) по алфавиту: слова по алфавиту с а до я или наоборот список учеников,  наименование товаров в магазине,   список песен, и т.д, и т.п. словарь является ярким примером такой сортировки. б)   в порядке убывания числа- по возрастанию или убыванию. товары по их количеству,  альбомы по количеству песен в них, города по количеству проживающих в них людей конституция рф – сортировка по номерам статей в порядке убывания. в) в хронологической последовательности даты- по возрастанию или убыванию сортировка:   по дате рождения  учеников,    по дате поступления товаров на склад, списка песен по дате их записи. учебник по : хронология событий.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны три натуральных числа. напишите программу, определяющую, существует ли треугольник с такими длинами сторон. если такой треугольник существует, то определите его тип (равносторонний, равнобедренный, разносторонний) в python, )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ilez03857
ea-office
stic1995
Segyn1218
TrubnikovKlimenok926
amarantmetall
Panda062000
Анатольевич
Анатольевич-Митюшин
Попов1946
struev2003260
dvpered
antilopa001
dmitrijku
agent-ulitka5