aananasAnastiya1270
?>

Составьте программу, которая бы складывала, вычитала, умножает два произвольных натуральных числа, задаваемых любым пользователем.

Информатика

Ответы

Bmashutav16

program dva_chisla;

var

    a,b,s,p,v: real;

begin

  writeln('введите два числа');

  readln(a,b);

  s: =a+b;

  writeln('сумма чисел ',a,' + ',b,' = ',s);

  v: =a-b;

  writeln('разность чисел ',a,' - ',b,' = ',v);

  p: =a*b;

  writeln('произведения чисел ',a,' * ',b,' = ',p);

end.

rikki07834591

напишу на qbasic.

cls

input "первое число=", a

input "второе число=", b

input "третье число=" c

d1=a+b+c

print "d1="; d1

d2=a-b-c

print "d2="; d2

d3=a*b*c

print "d3="; d3

end

 

germanleon
Const   nn=20; var   i,j,a,b,m,x,la,lb,p,ij,mn: integer;   s: string;   d: array[1..nn,1..nn] of integer; begin   {инициализация и вывод массива}   write('число строк и столбцов в массиве: ');   read(m,x);   write('диапазон значений элементов массива: ');   read(a,b);   str(a,s);   la: =length(s);   str(b,s);   lb: =length(s);   if la> lb then p: =la+1 else p: =lb+1;   randomize;   writeln('исходный массив');   for i: =1 to m do begin       for j: =1 to x do begin           d[i,j]: =random(b-a+1)+a;           write(d[i,j]: p)           end;       writeln       end;   {нахождение минимума}   if i> j then ij: =j else ij: =i;   mn: =d[1,1];   for i: =1 to ij do       for j: =1 to x-i do           if d[i,j]< mn then mn: =d[i,j];   writeln('минимальный элемент выше побочной диагонали равен ',mn) end. пример работы число строк и столбцов в массиве: 5 8 диапазон значений элементов массива: -50 50 исходный массив   -10 -18 -42 -33    6  15 -29  16   -5 -22    7 -49 -43 -44 -42  22   36 -29  19 -26 -14 -49 -39    2     2  35 -16  44  13  26 -12 -40   -50  10 -42 -13  29 -22 -48  34 минимальный элемент выше побочной диагонали равен -50
porotikova1004
//dev-c++ 5.11 (c) #include < stdio.h> #include < ctime> #include < stdlib.h> int main(void)   {const int m=5;   const int x=5;   int matrix[m][x],min,a,b;   srand(time(null));   scanf("%d %d",& a,& b);   for(int i=0; i< m; i++)   {for(int j=0; j< x; j++)     {matrix[i][j]=(rand()%(b+1-a))+a; //r=(rand()%(max+1-min))+min     printf("%d ",matrix[i][j]); }   printf("\n"); }   a=1;   min=matrix[0][0];   for(int i=0; i< m; i++)   {for(int j=0; j< x-a; j++)     if(min> matrix[i][j])     min=matrix[i][j];   a++; }   printf("%d",min);   return 0; } пример ввода: -30 30 пример вывода: 3 11 -18 21 27 22 -5 21 13 -11 -6 15 16 -28 -5 10 -15 6 -24 -3 -10 -15 25 -30 -30 -18

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая бы складывала, вычитала, умножает два произвольных натуральных числа, задаваемых любым пользователем.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artem
tabacoffee
krasa28vostok65
АлександрАнатолий
terma-msk1
Svetlana395
Татьяна Марина1287
Бочкарева Горохова1652
sirenashop25
Reznikova1075
stomcom01
Кожуховский398
miumiumeaow
Кириллов57
ksenia15-79
▲