Matveevanastya0170
?>

Напишите программу, которая находит в массиве целых чисел количество элементов, равных заданному значению x . возможно решать по-разному, например, использовать дополнительные массивы или даже не использовать массивы совсем. главное - вывести правильный ответ. вы должны ввести полный текст программы на java: необходимые импорты, один public класс в пакете по умолчанию (в коде отсутствует подстрока package), функцию комментарии на кириллице не разрешены. ввод осуществляется с консоли, вывод - на консоль. программа должна работать точно по протоколу, который показан в примерах. например, нельзя выводить ничего лишнего, скажем, фразу "введите n". входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x. гарантируется, что данные корректны и n < 10001. выходные данные программа должна вывести одно целое число – количество элементов массива, равных x . for example: } на java

Информатика

Ответы

Нана_Елена
Открытая архитектура- это архитектура компьютера, любого перефирийного устройства(устройства ввода-вывода) или по (программного обеспечения), на которые опубликованы спецификации(документ, в котором указаны все узлы и детали изделия), то есть любой производитель может разработать дополнительные устройства к системам с открытой архитектурой принцип открытой архитектуры   заключается в том, что производитель  не скрывает узлы и детали, из которых состоит компьютер. они  могут быть легко  заменены другими.большинство современных компьютеров- с открытой архитектурой. обратный пример- с закрытой архитектурой это продукция apple (айфон,айпад, макбук), к которым не подходят детали других производителейпо просту говоря, к любому компьютеру можно подключить любой принтер, мышку или другой гаджет не важно какого производителя
hotel-info
Const   nn=100; var   n,i,k,s: integer;   a: array[1..nn] of integer; begin   write('количество элементов в массиве: '); read(n);   randomize;   writeln('сформированный массив');   k: =0; s: =0;   for i: =1 to n do begin       a[i]: =random(100);       write(a[i],' ');       if (a[i] in [51..59]) then begin s: =s+a[i]; inc(k) end       end;   writeln;   writeln('на интервале [51..59] найдено элементов - ',k);   writeln('их сумма равна ',s) end. пример выполнения программы количество элементов в массиве: 20 сформированный массив 26 65 64 80 46 0 54 38 63 14 63 81 40 42 17 16 23 88 61 54 на интервале [51..59] найдено элементов - 2 их сумма равна 108 замечание если конструкция a[i] in [51..59] кажется незнакомой, её можно заменить на более длинную и менее эффективную (a[i]> 50) and (a[i]< 60)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая находит в массиве целых чисел количество элементов, равных заданному значению x . возможно решать по-разному, например, использовать дополнительные массивы или даже не использовать массивы совсем. главное - вывести правильный ответ. вы должны ввести полный текст программы на java: необходимые импорты, один public класс в пакете по умолчанию (в коде отсутствует подстрока package), функцию комментарии на кириллице не разрешены. ввод осуществляется с консоли, вывод - на консоль. программа должна работать точно по протоколу, который показан в примерах. например, нельзя выводить ничего лишнего, скажем, фразу "введите n". входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. в третьей строке записано число x. гарантируется, что данные корректны и n < 10001. выходные данные программа должна вывести одно целое число – количество элементов массива, равных x . for example: } на java
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

v79150101401
abrolchik8511
alanatan5757
polariskirov
iamhrusha
Ulianev77
Кирилл-Морозова
Rinatum1978
snk7777202
vik1223
stsnab
Kashtelyan Tamara847
Yelizaveta555
Galkin Vladimirovich729
Не(a) &amp; b + a &amp; не(b)​
ValerevnaRustam1072