ivanjeka87
?>

Составить программу, которая вычисляет произведение нечетных натуральных чисел от 1 до n , : ))

Информатика

Ответы

deputy810

program c1;

var

i,n: integer;

x: longint;

begin

x: =1;

write('введите n: ');

readln(n);

for i: =1 to n do

if (i mod 2=1) then x: =x*i;

writeln(x);

end.

 

aynaakzhigitova

var a,n,i: integer; beginwriteln('введи n'); readln(n); a: =1; for i: =1 to n do begina: =a*i; inc(i); end;

writeln('ответ: '); writeln(a); end.

dimiff5
Pascalabc.net 3.4.0, сборка 1671 от 31.05.2018 внимание! если программа не работает, обновите версию! №1 begin   var (a,b): =readinteger2('введите a,b: ');   if a.iseven then a-=1;   range(a,b,-2).println end. пример введите a,b: 18 4 17 15 13 11 9 7 5 №2 begin   var (a,b): =readinteger2('введите a,b: ');   range(b,a).aggregate(biginteger(,j)-> i*j).println end. пример введите a,b: 50 7 42241796113490802838350844675089956728302279956889600000000000 №3 begin   var n: =readinteger('n=');   for var i: =1 to n do       (1.to(('') end. пример n= 7 1 12 123 1234 12345 123456 1234567
Vyacheslavovich Mikhailovich1421
Function sum_del(x: longint): longint; var     s, i: longint; begin     s : = 0;     for i : = 1 to x div 2 do         if x mod i = 0 then             s : = s + i;     sum_del : = s; end; var     i, s1, s2: longint; begin     for i : = 1 to 100000 do     begin         s1 : = sum_del(i);         s2 : = sum_del(s1);         if (s2 = i) and (s1 < i) then             writeln(s1, ' ', i);     end; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая вычисляет произведение нечетных натуральных чисел от 1 до n , : ))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

imosal
vnolenev
dkvsadovoe
Андрееевич787
tigran87-87
mbykovskiy
Aleksei1463
Natalya1895
kokukhin
gladkihvv
Chuhnin195107364
tarhan1221
Вадимовна
uvarovig
Oksana-Kirakosyan1301