la-ronde737
?>

Написать программу в паскале: 1) вводятся 10 целых чисел. подсчитать количество четных среди них 2) вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры 3) вывести на экран все трехзначные числа-палиндромы, т.е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

Информатика

Ответы

ПаршинАндрей1928

var

  i, c : byte;

  t : integer;

begin

  c : = 0;

  for i : = 1 to 10 do

  begin

    read (t);

    if t mod 2 = 0 then inc (c);

  end;

  writeln (c);

end.

 

var

  n, i : integer;

begin

  read (n);

  for i : = 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i);

end.

 

var

  i : integer;

begin

  for i : = 100 to 999 do

    if i mod 10 = i div 100 then writeln (i);

end.

Igorevich_Aleksandrovna1599
Using system; namespace consoleapp {       internal class program {             private static void main() {                   var a = new int[10];                   var b = new int[10];                   var positives = new[] {0, 0};                   var r = new random(datetime.now.millisecond);                   for (var i = 0; i < a.length; i++) {                         a[i] = r.next(-100, 100);                         b[i] = r.next(-100, 100);                         a[i] = (a[i] < 0) ? 0 : a[i];                         positives[0] += (a[i] > 0) ? 1 : 0;                         positives[1] += (b[i] > 0) ? 1 : 0;                         console.write(a[i] + " ");                   }                   console.writeline();                   console.writeline("больше положительных элементов в массиве {0}", (positives[0] > positives[1]) ? "a" : "b");                   console.readkey();             }       } }
VladimirovnaSimonov
Большинство баз данных имеют  табличную структуру.  как мы  знаем, в табличной структуре адрес данных определяется пересече­нием строк и столбцов. в базах данных столбцы называются  поля­ми,  а строки —записями.  поля образуют  структуру базы данных,  а записи составляют информацию, которая в ней содержится. для того чтобы легко усвоить понятие структуры базы данных, надо представить себе пустую базу, в которой пока еще нет никаких данных. несмотря на то что данных в базе нет, информация в ней все таки есть. это структура базы, то есть набор полей. они определяют, что будет записано в эту базу и в каком виде.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале: 1) вводятся 10 целых чисел. подсчитать количество четных среди них 2) вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры 3) вывести на экран все трехзначные числа-палиндромы, т.е. такие числа, которые одинаково читаются как слева направо, так и справа налево.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

testovvanya
nelli-bi6
takerra
NikonA83
ann328389
gumirovane2294
goldglobustour725
rayon14
qwert28027170
elenak26038778
zipylin
Mikhail1369
borisrogovpr3407
moto-eskort
veravlad