Alyona
?>

Напишите программирование с#(си-шарпсоставить программу возведения заданного числа в третью степень, имеющую следующую закономерность: 1³=1 2³=3+5 3³=7+9+11 4³=13+15+17+19 5³=21+23+25+27+29 вот написала: using system; using system.collections.generic; using system.linq; using system.text; namespace consoleapplication11 { class program { public int getthird(int num) { int result = 0; int kv = num * num; if (num % 2 == 0) { for (int i = num/2; i > 0; { result += kv - i * 2 + 1; } for (int i = 0; i < num / 2; i++) { result += kv + i * 2 + 1; } } else { for (int i = (num - 1) / 2; i > 0 ; { result += kv - i * 2; } result += kv; for (int i = 0; i < (num - 1) / 2; i++) { result += kv + i * 2 + 2; } } return result; } static void main(string[] args) { console.writeline("введите натуральноe числo "); console.write("result="); int a = int.parse(console.; console.write("c="); int b = int.parse(console.; console.writeline("", b); console.read(); } } } исправьте ошибку

Информатика

Ответы

Гаевая1290

using system;

class program

{

private static int getthird(int num)

{

var result = 0;

var kv = num * num;

if (num % 2 == 0)

{

for (var i = num / 2; i > 0;

{

result += kv - i * 2 + 1;

}

for (var i = 0; i < num / 2; i++)

{

result += kv + i * 2 + 1;

}

}

else

{

for (var i = (num - 1) / 2; i > 0;

{

result += kv - i * 2;

}

result += kv;

for (var i = 0; i < (num - 1) / 2; i++)

{

result += kv + i * 2 + 2;

}

}

return result;

}

//оптимизированное свое решение, коротко и ясно

private static int getthirdoptimized(int num)

{

var result = 0;

var kv = num * num - num + 1;

for (var i = 0; i < num; i++)

{

result += kv + i * 2;

}

return result;

}

private static void main()

{

console.writeline("введите натуральноe числo ");

var i = int.parse(console.;

console.writeline("{0}^3 = {1} = {2} = {3}", i, i * i * i, getthird(i), getthirdoptimized(i));

console.read();

}

}

sashakrotova943
В растровой графике при увеличении всегда есть потеря информации и «ступенчатый эффект», вес файла зависит от разрешения и глубины цвета, закодировать можно любое изображение, оно состоит из пикселей, изображение которое мы видим на экране компьютера/телефона использует цветовую палитру RGB (Red Green Blue), при печати используется палитра CMYK (Cyan Magenta Yellow KeyColour(чёрный))
векторная графика использует графические примитивы, закодировать можно не все изображения, при увеличении нет потери информации, не такая хорошая передача цвета как в растровой графике, тк используются примитивные цвета
ИринаАлександровна
Если вам нужно на паскале, то ловите. числа в массив   рандомно. диапазон (-50, 50): var mass: array[1..30] of real;     i, j: integer;     ise: boolean; begin randomize; ise : = true; for i : = 1 to 30 do begin mass[i] : = random (100) - 50; end; for i : = 1 to 30 do begin writeln('mass[', i, '] = ', mass[i]); end; for i : = 1 to 30 do begin    for j : = 1 to 30 do begin     if i < > j then begin       if mass[i] = mass[j] then begin         writeln('массив не уникален! ');         ise : = false;       end;     end;   end; end; if ise = true then writeln('массив уникален! '); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программирование с#(си-шарпсоставить программу возведения заданного числа в третью степень, имеющую следующую закономерность: 1³=1 2³=3+5 3³=7+9+11 4³=13+15+17+19 5³=21+23+25+27+29 вот написала: using system; using system.collections.generic; using system.linq; using system.text; namespace consoleapplication11 { class program { public int getthird(int num) { int result = 0; int kv = num * num; if (num % 2 == 0) { for (int i = num/2; i > 0; { result += kv - i * 2 + 1; } for (int i = 0; i < num / 2; i++) { result += kv + i * 2 + 1; } } else { for (int i = (num - 1) / 2; i > 0 ; { result += kv - i * 2; } result += kv; for (int i = 0; i < (num - 1) / 2; i++) { result += kv + i * 2 + 2; } } return result; } static void main(string[] args) { console.writeline("введите натуральноe числo "); console.write("result="); int a = int.parse(console.; console.write("c="); int b = int.parse(console.; console.writeline("", b); console.read(); } } } исправьте ошибку
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Fedorov1283
volna22051964
Salko17
Valeria123864531
svetkaiv
temik10808564
whiskyandcola
Ligacom
Vipnikavto58
Aleksandr362
Nadegdasb
Artur-62838
dsnewline
Джамалутдинова Докучаев
mb9037479491
▲