Mikhail579
?>

Решить в паскале: составить программу, проверяющую, является ли заданное натуральное число палиндромом, т.е. таким, которое читается одинаково слева направо и справа налево(например: 23132

Информатика

Ответы

YeVgenii

var n, m, p: word; begin write('enter number: '); readln(n); m : = n; p : = 0; while m > 0 do begin p : = p * 10 + m mod 10; m : = m div 10; end; if n = p then writeln('palindrome') else writeln('not palindrome'); readln; end.

Oslopova
1) частота дискретизации 44.1 кгц означает, что в секунду делается 44 100 отсчетов. разрешение 16 бит (т.е. 16/8=2 байта) требует для хранения каждого отсчета 2 байта, а для хранения информации за 1 секунду - 2 х 44 100 = 88 200 байт. две минуты - это 2 х 60 = 120 секунд и тогда общий объём составит 88 200 х 120 = 10 584 000 байт или 10 584 000 / 1024 = 10 335.94 кбайт, или 10 335.94 / 1024 = 10.1 мбайт и все это - для одного канала записи (монофонической). если запись стереофоническая - то каналов два и потребуется 2 х 10.1 = 20.2 мбайта и т.д. 2) в этой много неизвестных, а ход её решения обратный по отношению к предыдущей . 2.6 мбайта = 2.6 х 1024² = 2 726 297.6 байт. в одной минуте 60с, поэтому объем информации за одну секунду не может превышать 2 726 297.6 / 60 = 45 438.3 байт. а теперь это число нужно разделить на произведение трех значений: количества каналов записи, частоты дискретизации в герцах и разрешения (количества байт, отводимых для хранения одного отсчета). все эти значения нам неизвестны, поэтому у нет однозначного решения. например, если канал один, а разрешение равно 1 байту, то частота дискретизации не может превышать 45 438 байт, что примерно соответствует общепринятой частоте 44 100 гц (44.1 кгц).
ktatarinova
// pascalabc.net 3.0, сборка 1128 function sum(a: array of real): real; begin   result: =0;   foreach var x in a do       if x> 10 then result+=x end; procedure half(a: array of real); begin   var s: =sum(a)/2;   for var i: =0 to a.length-1 do a[i]/=s end; procedure printrealarray(a: array of real); begin   foreach var x in a do write(x: 0: 3,' ');   writeln end; begin   var n: =readinteger('количество элементов массива: ');   var p: =arrrandomreal(n,0,20);   writeln('исходный массив'); printrealarray(p);   half(p);   writeln('результирующий массив'); printrealarray(p) end. тестовое решение: количество элементов массива: 10 исходный массив 2.835 3.159 11.777 19.562 1.392 8.941 15.501 14.392 7.945 12.443 результирующий массив 0.077 0.086 0.320 0.531 0.038 0.243 0.421 0.391 0.216 0.338

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в паскале: составить программу, проверяющую, является ли заданное натуральное число палиндромом, т.е. таким, которое читается одинаково слева направо и справа налево(например: 23132
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ribcage52
zhannasokortova
baulinanatalia7201
Суравцова_Алексей669
Dmitrievna405
lepekhov4011
rukodelnizza1
semenov-1970
Ольга Сергей1822
Asira926
И.Д.1065
aeykin
Advantage9111
ЕкатеринаРустам
a1rwalk3r