Долбоебков_Алексей27
?>

Решите какое-либо 1.напишите программу, которая в последовательности целых чисел определяет количество четных отрицаетльных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество четных отрицательных чисел. входные данные -1 7 2 -6 0 выходные данные 1 2 напишите программу, которая в последовательности целых чисел определяет количество нечетных положительных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество нечетных положительных чисел: -1 7 2 -6 0 выходные данные 1

Информатика

Ответы

bruise6

1)

program pr; uses crt; var a,k,k1: integer; beginwriteln('введите a'); readln(a); k1: =1; k: =0; while (a< > 0) and (k1< 1000) dobeginif (a< 0) and (a mod 2=0) and (abs(a)< =30000) then k: =k+1; k1: =k1+1; readln(a); end; writeln('k=',k); readln; end.

 

2)program pr; uses crt; var a,k,k1: integer; beginwriteln('введите a'); readln(a); k1: =1; k: =0; while (a< > 0) and (k1< 1000) dobeginif (a> 0) and (a mod 2< > 0) and (abs(a)< =30000) then k: =k+1; k1: =k1+1; readln(a); end; writeln('k=',k); readln; end.

Olga Arutyunyan
Const   n = 20; var   a,b: array[1..n] of integer;   i, j, i2: integer; begin   randomize;   writeln('элементы массива');   j: =0;   for i : = 1 to n do   begin       a[i] : = random(51)-25;       write(a[i]: 4);       if a[i]< 0 then begin inc(j); b[j]: =a[i] end;   end;   writeln;   for i : = 1 to n do       if a[i]> =0 then begin inc(j); b[j]: =a[i] end;   writeln('результат');   for i : = 1 to n do write(b[i]: 4);   writeln end. тестовое решение: элементы массива     3  14  10    1  -3  -2 -11 -12  13    1  17  13    8  24  -3 -23 -17  -8 -10 -22 результат   -3  -2 -11 -12  -3 -23 -17  -8 -10 -22    3  14  10    1  13    1  17  13    8  24
dashafox8739
Const   n = 10; var   a: array[1..n] of integer;   i: integer; begin   randomize;   writeln('исходный массив');   for i : = 1 to n do   begin       a[i] : = random(51) - 25;       write(a[i]: 4);   end;   writeln;   writeln('результирующий массив');   for i : = 1 to n do   begin       if a[i] > 0 then a[i] : = a[i] div 2 else a[i] : = i;       write(a[i]: 4);   end;   writeln; end. тестовое решение: исходный массив     5 -19 -24 -21  -4  14 -18 -21    2 -14 результирующий массив     2    2    3    4    5    7    7    8    1  10

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решите какое-либо 1.напишите программу, которая в последовательности целых чисел определяет количество четных отрицаетльных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество четных отрицательных чисел. входные данные -1 7 2 -6 0 выходные данные 1 2 напишите программу, которая в последовательности целых чисел определяет количество нечетных положительных чисел. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0(0- признак окончания ввода, не входит в последовательность. количество чисел не превышает 1000.введеные числа по модулю непревышают 30000. программа должна вывести одно число количество нечетных положительных чисел: -1 7 2 -6 0 выходные данные 1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

isaev
MAXIM76748
zorinka777
samirmajbubi
papushinrv4985
rb-zakaz
davidovalbert6
strannaya2018
soclive7762
Stepan Rastorgueva850
Коваль1974
Yurii537
mrropevvv
AndreiFaikov1943
Milovidova