vinokurova88251
?>

Составить программу для нахождения данного натурального числа а) всех его делителей; б)сумму его четных делителей

Информатика

Ответы

uchpaot
#include < stdio.h>   #include < stdlib.h> int main()  {      int n=10;     int max = 20, min = 10;     float a[n];     float b;     float sum=0;     srand (time(null));       for (int i=0; i< n; i++) {         a[i] = (float) rand() / rand_max*(max-min)+min;         printf ("%.2f ", a[i]);     }     printf("\n");     printf("b = ");     scanf("%f",& b);     for (int i = 0; i< n; i++) {     if (a[i] > b) sum+=a[i];     }     printf("sum = %.2f\n", sum);     return 0; } пример: 11.93 14.67 18.25 13.99 14.33 11.68 15.80 17.83 13.61 18.20   b = 15sum = 70.08
volodinnikolay19
1) один символ (например буква) = 1 байт. 1 байт = 8 бит (или по другому - 8 разрядов). некоторые символы, например иероглифы не умещаются в 1 байт потому что их много, поэтому для них используют не один байт, а больше. если для символа нужно больше 8 бит, то прибавляют не недостающее число битов, а удваивают число байт. поэтому буквы (символы) или 8-ми разрядные (1 байт), или 16-ти разрядные (2 байта), или 32-х разрядные (4 байта). 2) мама - это 4 обычных символа, или 4 байта (32 бита). 3) один байт, или 8 бит. 4) 15 байт - количество всех букв + пробелы + точка. или 120 бит. 5) 21 байт, или 168 бит (все буквы + пробел + точка). 6) 7 букв = 7 байт. 7) 20 х 40 = 800 символов/страница. 2 страницы = 1600 символов. 1600 символов = 1600 байт, или 1600 х 8 = 12800 бит. 8) 20 байт. 9) большой латинской "ай" - "i". 10) латинская буква "n". 11) маленькая латинская "ай" - "i". из формулы хартли n=

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для нахождения данного натурального числа а) всех его делителей; б)сумму его четных делителей
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

simonovaliubov5852
mototeh69
aza2103
ngoncharov573
Tarakanova_pavel
sharikplushelen
morozov1605
qwe54344
Павел
Kochetova92
phiskill559
balabina-Olesya
apromovich1
msk27
lider-mpl550