Vladimir-Tamara1359
?>

Составить программу печатающую значение true если указанное высказывание истина и false в противном случае: .сумма двух целых чисел кратна 2.

Информатика

Ответы

sohrokova809

var

  a, b: integer;

begin

  write('введите первое число '); readln(a);

  write('введите второе число '); readln(b);

  writeln((a + b) mod 2 = 0);

end.

vladimir72tatarkov1317

Объяснение:

1) 512 * 1024(чтобы перевести в килобайты) * 1024(чтобы перевести в байты) * 8(чтобы перевести в биты) = 2^9 * 2^10 * 2^10 * 2^3 = 2^32

2) 128 * 1024(в мб) * 1024(в кб) * 1024(в байты) = 2^7 * 2^10 * 2^10 * 2^10 = 2^37

3) 32 * 1024(в байты) * 8(в биты) = 2^5 * 2^10 * 2^3  = 2^18

4) 2^39 бит / (8 (в байты) * 1024(в килобайты) * 1024(в мегабайты) * 1024( в гб) = 2^39 / ( 2^3 * 2^10 * 2^10 * 2^10) = 2^39 / 2^33 = 2^6 = 64

5) 2^35 байт / ( 2^10(в кб) * 2^10(в мб) ) = 2^35 / 2^20 = 2^15

6) 2^27 бит / ( 2^3(в байты) * 2^10(в кб) * 2^10(в мб)) = 2^27 / 2^23 = 2^4 = 16

vallium8354

pascalabc.net

type

  vector = array of real;

function operator +(a, b: vector): vector;

    extensionmethod : = a.zip(b, (p, q) -> p + q).toarray;

function operator -(a, b: vector): vector;

    extensionmethod : = a.zip(b, (p, q) -> p - q).toarray;

function operator *(s: real; a: vector): vector;

    extensionmethod : = a.convertall(p -> p * s);

begin

  var a: vector : = readarrreal('вектор a: ', 3);

  var b: vector : = readarrreal('вектор b: ', 3);

  var c: vector : = readarrreal('вектор c: ', 3);

  var k : = readreal('k =');

  println(k * (a + b) + (1 - k) * (a + c))

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу печатающую значение true если указанное высказывание истина и false в противном случае: .сумма двух целых чисел кратна 2.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

UvarovAndrei
Орлова
tatiyanabe2013727
Египтян2004
Vrezh
Dr-motoshop
Мануэлла
nchorich55
makashi28
Vikkitrip
hotnuts
nnbeyo
milkiev
leonidbaryshev19623
▲