var
a, b, c: real; {c - буферная переменная, в которой будет хранится значение переменной а}
begin
writeln('введите 2 числа');
readln(a, b); //вводим значения переменных а и b
writeln(a, ' ', b); //печатаем значения переменных а и b
c: = a; //присваиваем переменной с значение переменной а
a: = b; //присваиваем переменной а значение переменной b
b: = c; //присваиваем переменной b значение переменной c
writeln(a, ' ', b); //печатаем измененные значения
end.
1) достаточно большой объем
2) не большая цена (по сравнению в переносными внешними жесткими дисками)
3) быстрый способ переноса информации
4) не требуется домолнительных прграмм для сохранения информации
5) есть возможность работать прямо с носителя.
многое это есть и у других носителей, но например дискеты маленькой памятью, для работы сс дисками надо иметь и дисковод и, что бы записать туда информацию, необходимо программу. а переносной внешний жеский диск имеет достаточную стоимость, что не покараману некоторым.
Поделитесь своими знаниями, ответьте на вопрос:
Суммарный индекс паскал быстрее имя входного файла: стандартный ввод имя выходного файла: стандартный вывод ограничение по времени: 1 секунда ограничение по памяти: 256 мегабайт в параллельной вселенной винни — не просто медведь, а медведь-айтишник. летом он выбрал жертву, которая не может программировать, и дал ей возможность получить сообщение с готовым программным кодом от случайного человека из другой вселенной. этот человек — вы! для того, чтобы ему , вам нужно вывести элемент массива a на позиции, равной сумме позиций минимального и максимального элемента массива. ему. формат входных данных в первой строке вводится n (1 ⩽ n ⩽ 50) — количество чисел в массиве a. во второй строке вводится n чисел ai (0 ⩽ ai ⩽ 50) — элементы массива a. если максимальных или минимальных значений несколько, используйте первый из них. формат выходных данных выведите искомый элемент или строку «vne massiva», если искомый индекс выходит за границы массива. примеры стандартный ввод стандартный вывод 5 1 5 2 4 3 2 3 1 2 3 vne massiva 1 5 vne massiva
он считал что прсто так ничего не бывает и ему было стыдно брать