var s: string; k,j,f: integer; ch: char; begin read(s); f: =0; for k: =1 to length(s) do for j: =1 to length(s) do if ((s[k]=s[j]) and (k< > j)) then begin f: =1; ch: =s[k]; end; if f=1 then writeln('yes - ',ch) else write('no'); readln; end.
qwert28027170
08.10.2020
1. для групповых операций с файлами используются маски имен файлов. маска представляет собой последовательность букв, цифр и прочих допустимых в именах файлов символов, в которой также могут встречаться следующие символы. символ «? » (вопросительный знак) означает ровно один произвольный символ. символ «*» (звездочка) означает любую последовательность символов произвольной длины, в том числе «*» может задавать и пустую последовательность. в каталоге находятся 5 файлов: fort.docx; ford.docx; lord.doc; orsk.dat; port.doc. определите, по какой из масок из них будет отобрана указанная группа файлов: fort.docx; ford.docx; lord.doc; port.doc. 1) *o? *.d? * 2) ? o*? .d* 3) *or*.doc? 4) ? or? .doc?
martinzdraste
08.10.2020
// pascalabc.net 3.2, сборка 1407 от 18.03.2017 // внимание! если программа не работает, обновите версию! function countperfect(n: integer): array of biginteger; begin var cat: =new biginteger[51]; (cat[0],cat[1]): =(1,1); for var i: =2 to n do for var j: =0 to i-1 do cat[i]+=cat[j]*cat[i-j-1]; result: =cat end; begin var cat: =countperfect(50); readlnstring.tointegers.select(n-> cat[n div 2]).println; end. пример 1 43 19 42 7 1 24466267020 4862 24466267020 5
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Тема: цикл с предусловием. : ввести целое число и определить, верно ли, что в его записи есть две одинаковые цифры. в паскале напишите программу
program a; uses crt;
var s: string; k,j,f: integer; ch: char; begin read(s); f: =0; for k: =1 to length(s) do for j: =1 to length(s) do if ((s[k]=s[j]) and (k< > j)) then begin f: =1; ch: =s[k]; end; if f=1 then writeln('yes - ',ch) else write('no'); readln; end.