vickuznetsova8677
?>

Написать программу на языке пакаль. ввести 3 числа, вычислить сумму чисел и их произведение вывести на экран меньшее значение.

Информатика

Ответы

Кирилл-Анна1023

var a,b,c,sum,proiz: integer;

begin

readln (a,b,c);

sum: =a+b+c;

proiz: =a*b*c;

 

if (sum< proiz) then writeln (sum)

else

writeln (proiz);

readln;

end.

Kisuha8465
13 сентября 1956 года, то есть более полвека назад компания ibm представила свой первый накопитель на жестких магнитных дисках (позднее данные устройства получили полуофициальное прозвище «винчестер») .  и это изобретение со временем фактически создало огромную индустрию магнитных накопителей, без которых сейчас немыслимо ни одно мало-мальски мощное вычислительное устройство, поскольку подавляющее большинство информации, которыми оперируют эти самые вычислительные устройства, хранится именно на магнитных носителях. 
serkan777
#include < stdio.h> #define maxsize 105 typedef struct station{       int x, y, z; } station; int abs(int x){       return x > = 0 ? x : -x; } int min(int a, int b){       return a < = b ? a : b; } int main(){       file *ist, *ost;             station s[maxsize];       int w[maxsize][maxsize];       int inc[maxsize];       int n,i,j,k,m,l,r;             ist = fopen("input.txt","r");             fscanf(ist, "%d", & n);       for(i = 0; i < n; i++) fscanf(ist, "%d %d %d", & s[i].x, & s[i].y, & s[i].z);             fclose(ist);             for(i = 0; i < n; i++) inc[i] = 0;             for(i = 0; i < n; i++)       for(j = i; j < n; j++)             w[i][j] = w[j][i] = min(abs(s[i].x - s[j].x), min(abs(s[i].y - s[j].y), abs(s[i].z - s[j].z)) );             r = 0; k = 1;       inc[0] = 1;       while(k < n){             m = -1;             for(i = 0; i < n; i++) if(inc[i])             for(j = 0; j < n; j++) if(! inc[j])                   if (m == -1 || w[i][j] < m) m = w[i][j], l = j;             r += m;             inc[l] = 1;             k++;       }             ost = fopen("output.txt","w");       fprintf(ost,"%d", r);       fclose(ost);             return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке пакаль. ввести 3 числа, вычислить сумму чисел и их произведение вывести на экран меньшее значение.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pimenov5
themolodoy
Давид-Александр
nataliagoncharenko
Vyacheslavovich-Gubanov
Елена Надыч524
igevskoemuseumkec
Александра-Андрей909
Pautova1119
zabrodin
Каныбек698
Pastel-sova
iskypka
zoomagazinkotmatroskin
ckiras9