ams-sim
?>

Написать программу которая проверяет состоит ли трёхзначное число из одинаковых цифр ( например 555 с объяснением. для 7 класса. предмет: информатика.

Информатика

Ответы

rstas
Procedure chisla(n : integer); var    a : integer; begin      if (n < 1) then  writeln        else      begin          read(a);         if (abs(a) < 1000) then        begin            chisla(n-1);             write(a,' ');           end        else              chisla(n);       end; end;   function readn() : integer; var    n : integer; begin    write('n=');     readln(n);     if not(n in [0..1000]) then        n : = readn();     readn : = n; end;   var    n : integer;   begin    n : = readn();     writeln('введите ', n, ' целых чисел через пробел и нажмите enter');       chisla(n); end.
Бурмистрова-Ирина660
Const   m=10; var   r: array[1..m,1..m] of integer;   i,j,t,p,q: integer; begin   write('введите номер строки (1..10) для перестановки: ');   read(q);   randomize;   writeln('исходный массив');   for i: =1 to m do begin       for j: =1 to m do begin           r[i,j]: =random(90)+10;           write(r[i,j]: 3);           end;       writeln   end;   p: =1;   for i: =2 to m do       if r[i,i]< r[p,p] then p: =i;   if p< > q then begin       writeln('результирующий массив');       for j: =1 to m do begin           t: =r[p,j]; r[p,j]: =r[q,j]; r[q,j]: =t           end;       for i: =1 to m do begin           for j: =1 to m do write(r[i,j]: 3);           writeln           end       end end.                      пример введите номер строки (1..10) для перестановки: 3 исходный массив   50 86 52 85 96 69 44 51 20 77   55 79 39 73 98 74 65 65 63 80   64 89 83 55 98 74 85 63 90 52   37 42 64 84 66 78 67 31 56 34   69 18 34 48 42 44 12 91 67 47   72 19 14 22 53 61 13 97 87 31   83 80 61 67 50 22 25 55 16 29   16 44 19 39 20 55 65 44 23 63   72 93 96 52 79 27 38 52 40 15   75 70 44 34 50 88 57 66 97 29 результирующий массив   50 86 52 85 96 69 44 51 20 77   55 79 39 73 98 74 65 65 63 80   83 80 61 67 50 22 25 55 16 29   37 42 64 84 66 78 67 31 56 34   69 18 34 48 42 44 12 91 67 47   72 19 14 22 53 61 13 97 87 31   64 89 83 55 98 74 85 63 90 52   16 44 19 39 20 55 65 44 23 63   72 93 96 52 79 27 38 52 40 15   75 70 44 34 50 88 57 66 97 29

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая проверяет состоит ли трёхзначное число из одинаковых цифр ( например 555 с объяснением. для 7 класса. предмет: информатика.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgamalochinska
ВитальевичЕвгеньевич346
Yurevich-Vladimirovich
genya1509
alex13izmailov
Morozova-Starikov
NikonA83
sttig
nataliagorki476
Soliyabronzoni
Ольга Сергей1822
Суравцова_Алексей669
kuzinnv1968
Mikhailova
olg53362928