evainvest1
?>

Вывести на экран все трехзначные числа в которых хотя бы две цифры повторяются в паскале

Информатика

Ответы

СмыковаДарья1969

var a,b,c,d: integer; begin      a: =100;     repeat        b: =a mod 10;         c: =(a div 10) mod 10;         d: =((a div 10) div 10) mod 10;         if(b=c) or (c=d) or (b=d) then writeln(a);         inc(a);     until(a> 999);     readln; end.

Yevgeniya1807
Программирование циклических алгоритмов Цикл – это команда исполнителю многократно повторить указанную последовательность команд. Три основных типа циклов : • Цикл с предусловием - while (цикл-ПОКА) • Цикл с постусловием - repeat (цикл-ДО) • Цикл с заданным числом повторений - for (цикл с параметром) Программирование циклов с заданным условием продолжения работы Цикл с предусловием – пока истинно условие цикла, выполняется тело цикла. Цикл с заданным условием продолжения работы (цикл-ПОКА) программируется в языке Паскаль с оператора while. Общий вид оператора: • while <условие> do <оператор> Здесь: • <условие> — логическое выражение; пока оно истинно, выполняется тело цикла; • <оператор> — простой или составной оператор, с которого записано тело цикла. условие тело цикла ДА НЕТ Запишем на языке Паскаль алгоритм получения частного q и остатка г от деления целого числа х на целое число у без использования операции деления. program ostatok; var х, у, q, r: integer; begin writeln (’Частное и остаток’); write ('Введите делимое х-> ’) ; readln (х); write (’Введите делитель у->’); read (у); r:=х; q:=0; while r>=y do begin r:=r-y; q:=q+l end; writeln ('Частное q=’, q); writeln (’Остаток r=’, r) end. Программирование циклов с заданным условием окончания работы. Цикл с постусловием – тело цикла выполняется до удовлетворения условия. Цикл с заданным условием окончания работы (цикл-ДО) программируется в языке Паскаль с оператора repeat. условие тело цикла ДА НЕТ Общий вид оператора: repeat <оператор1; оператор2;… > until <условие> Здесь: <оператор1>; <оператор2>; ...- операторы,образующие тело цикла; <условие> — логическое выражение; если оно ложно, то выполняется тело цикла. Необходимо решить задачу: Спортсмен приступает к тренировкам по следующему графику: в первый день он должен пробежать 10 км; каждый следующий день следует увеличивать дистанцию на 10% от нормы предыдущего дня. Как только норма достигнет или превысит 25 км, необходимо прекратить её её увеличение и далее пробегать ежедневно ровно 25 км. Начиная с какого дня спортсмен будет пробегать 25 км? Запишем на языке Паскаль алгоритм решения задачи о графике тренировок спортсмена. program sportsmen; var i: integer; х: real; begin writeln('График тренировок'); i:=1; x:=10; repeat i:=i+l; x:=x+0.1*x; until x>=25; writeln (’Начиная с ‘ , i, ‘ –го дня спортсмен будет пробегать 25 км’) end. Программирование циклов с заданным числом повторений Цикл с заданным числом повторений (цикл-ДЛЯ) программируется в языке Паскаль с оператора for. Его общий вид: for <параметр>:=<начальное_значение> to <конечное_значение> do <оператор> Здесь: <параметр> — переменная целого типа; <начальное_значение> и <конечное_значение> — выражения того же типа, что и параметр, вычисляемые перед началом цикла; <оператор> — простой или составной оператор — тело цикла. При выполнении этого оператора после каждого выполнения тела цикла происходит увеличение на единицу параметра цикла; условием выхода из цикла является превышение параметром конечного значения. Запишем на языке Паскаль алгоритм вычисления степени с натуральным показателем п для любого вещественного числа а. program stepen; var i, n: integer; a, у: real; тело цикла i=i1,i2…in begin writeln('Возведение в степень’); write (’Введите основание а»’); readln(а); write (’Введите показатель n» ’); readln(n); у:=1; for i:=l to n do y:=y*a; writeln ( ’an=’ , у) end. В заданиях Л и М применяется последний случай циклического алгоритма, т.е. цикл с заданным числом повторений …for i:=15 to 56 do s:=s+i… Задания Н и О на генератор псевдослучайных чисел Random, см. в следующей ссылке!

Объяснение:

ver2bit
2-хранение информации 3- ввода: клавиатура, мышь, сканер  вывода: монитор, калонки, принтер 4-в двоичном коде 5-это  часть системы компьютерной  памяти, в которой временно хранятся данные и команды, необходимые процессору для выполнения им операции 6-  это память, предназначенная для длительного хранения программ и данных 7- комплекс взаимосвязанных программ, предназначенных для ресурсами компьютера и организации взаимодействия с пользователем. 8-  операционные системы позволяют в каждый момент времени решать только одну . такие системы обычно позволяют запустить одну программу в основном режиме. 9- системы позволяют запустить одновременно несколько программ, которые будут работать параллельно. 10-  единица измерения количества информации. 11- это наука  о способах и методах представления, обработки, передачи и хранения информации с эвм 12- главный вычислительный элемент компьютера 13- совокупность программ системы обработки информации и программных  документов, необходимых для эксплуатации этих программ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вывести на экран все трехзначные числа в которых хотя бы две цифры повторяются в паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

info9
amaraks67
Бунеева
IrinaSolodukhina1495
Mbkozlov6
cat2572066
Tane4ka2110
dentinnsmr467
zdl2008
Олимов Протопопова
Сообщение на тему роспись туеска
Анатольевич-Митюшин
m-zolotukhina2
MikhailSvetlana
Dmitriy793
cholga69