makscska22879
?>

Паскаль. f(x)= -3х^2-x^2-x, если х< =-2 или 2х^2-3х, если х> -2 нужно составить программу, , .

Информатика

Ответы

volodin-alexander

  program funct;

uses crt;

var x,rez: real;

begin

      clrscr;

      write('введите x: ');

      readln(x);

      if (x< =-2) then rez: =-3*(x**x)-x

          else rez: =2*(x*x)-3*x;

      writeln('f(x)=',rez: 5: 5);    

      readkey;

 

end. 

 

 

tarkhanovilya
Const n=4;       m=3; var a: array[,] of integer;     b: array of integer;     i,j,k: integer; begin   setlength(b,n*m);   setlength(a,n,m);   randomize;   writeln('исходный массив: ');   for i: =0 to n-1 do   begin     for j: =0 to m-1 do       begin          a[i,j]: =random(-10,10);         write(a[i,j]: 4);       end;       writeln;   end;   // удаление строк массива     k: =0;   for i: =0 to n-1 do     if a[i,0]< =a[i,m-1] then     begin       k: =k+1;       for j: =0 to m-1 do        b[(k-1)*n+j]: =a[i,j];     end; // печать нового массива       writeln('новый массив: ');     setlength(a,k,m);   for i: =0 to k-1 do   begin     for j: =0 to m-1 do     begin       a[i,j]: =b[i*n+j];       write(a[i,j]: 4);     end;         writeln;   end;   end.исходный массив:   -3   5   -5     2   3   5   -8   3   -2     3   -4   -7 новый массив:     2   3   5   -8   3   -2
Daulyatyanov1266
Var       i, count, number: integer; begin       count : = 0;       i : = 0;       writeln('введите последовательность чисел');       repeat               readln(number);               if (number > = 100) and (number < = 999) and (number mod 4 = 0) then                       count : = count + 1;               i : = i + 1       until (number = 0) or (i > = 1000);             writeln('кол-во 3значных чисел кратных 4 =', count); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. f(x)= -3х^2-x^2-x, если х< =-2 или 2х^2-3х, если х> -2 нужно составить программу, , .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ragimovelshad
ea9824165833886
osipovasalex5316
Pokupatel
Mikuspavel2
Komarovsergeysk
lighturist
mary---jane49
muzaffarovich-Sergei1777
u-bhank
skorpion7228528
volkovaoksana19806037
Volkovapavel
tushina2020
vit010916
▲