jim2k
?>

Составить программу в паскале! ! ! дано двузначное число. определить: а) какая из его цифр больше, первая или вторая; б) одинаковы ли его цифры.

Информатика

Ответы

vovababkin1477

var

  c: integer;

begin

  write('введите число '); readln(c);

  c : = abs(c);

  if c div 10 > c mod 10 then

      writeln('первая цифра больше второй')

  else

      if c div 10 < c mod 10 then

          writeln('вторая цифра больше первой')

      else

          writeln('цифры равны');

end.

   

 

shef3009
1) a+(a*b) =a a   b     a*b     a+a*b 0   0     0           0 0   1     0           0 1   0       0           1 1   1     1           1 2)   a*(a+b) =a a   b   a+b     a*(a+b) 0   0     0         0 0   1     1         0 1   0     1         1 1   1     1         1
compm
А) алгоритмa: = 9                       a=9b: = a mod 5             b=4b: = b*10                   b=40a: =b div 5-3             a=8-3=5 (сначала выполняем div, потом "-")ответ:   b=40 б) алгоритмa: = 123                   а=123b: = a div 10             b=12b: = b/4+2               b=5b: = b*25+2             b=127a: = a+ b                 a=250 ответ:   b=127

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу в паскале! ! ! дано двузначное число. определить: а) какая из его цифр больше, первая или вторая; б) одинаковы ли его цифры.
Ваше имя (никнейм)*
Email*
Комментарий*