Abespal
?>

Написать программу в python! даны действительные коэффициенты a, b, c, при этом a ! = 0. решите квадратное уравнение ax²+bx+c=0 и выведите все его корни. формат ввода вводятся три действительных числа. формат вывода если уравнение имеет два корня, выведите два корня в порядке возрастания, если один корень — выведите одно число, если нет корней — не выводите ничего. тест 1 входные данные: 1 -1 -2 вывод программы: -1 2 тест 2 входные данные: 1 2 1 вывод программы: -1 тест 3 входные данные: 1 -7.5 3 вывод программы: 0.423966 7.07603

Информатика

Ответы

ГазалиеваКозак

m(mg)= 10/2=5 г так как соотношени 

mg + 2hcl=mgcl2+ h2

медь с соляной кислотой не реагирует

н  (mg) = 0.2 моль

  пропорция 

1моль -1моль

0.2 моль- х моль

х=0.2 моль

объем равен 0.2*2=0.4 литра

 

 

 

 

 

 

 

 

Wlad967857

program z1;

uses crt;

var a,i: integer;

        p: longint;

begin

    clrscr;

      p: =1;  

      write('введите число а: ');

      readln(a);  

      for i: =a to 100 do  

          p: =p*a;

    writeln('произведение всех чисел от  ',a,'до 100: ',p);

    readkey;

end. 

 

program z2;

uses crt;

var s,i: integer;

i: =2; s: =0;

while(i< =98) do

    begin 

        s: =s+i;  

          i: =i+2;

end;

    clrscr;

      write('сумма последовательности: ',s);    

    readkey;

end. 

 

program z3;  

uses crt;

var a,i: integer;

begin     

      clrscr;

      a: =0;      

      for i: =100 to 999 do

          if ((i mod 5)=0 and (i mod 21)=0) then

                a: =a+1;                    

      write('количество 3-значных чисел делящихся без остатка на 5 и 21: ',a);  

    readkey;

end. 

 

program z4;  

uses crt;

var a,i,s: integer;

begin     

      clrscr;

        s: =10:  

        write('введите количество тренировочных дней: ');    

        readln(a);

          for i: =2 to a do

                s: =s+3;

        write('суммарное расстояние: ',s);        

readkey;

end. 

 

program z5;

uses crt;

var a,i,n,s: integer;    

begin     

      clrscr;

      write('введите количество отрядов: ');

      readln(n);  

      s: =0;  

 

      for i: =1 to n do

          begin

                write('введите количество детей в  ',i ,'-м отряде: ' );  

 

                readln(a);

                clrscr;  

                s: =s+a;

          end;      

    writeln;

    writeln('общее количество детей в лагере: ',s);

    readkey;

end. 

 

vikanikita

1)

var

  a: real;

  x, y: integer;

 

begin

  writeln('введите дробное число');

  readln(a);

  x: = trunc(a);

  y: = frac(a);

  writeln(x, ' рублей ', y * 100, ' копеек');

  readln;

end.

2)

var

  n: 100..999;

  a, b, c: 0..9;   //a - сотни, b - десятки, с - единицы

 

begin

  writeln('введите трехзначное число');

  readln(n);

  a: = n div 100;

  b: = (n mod 100) div 10;

  c: = n mod 10;

  writeln('сумма цифр:   ', a + b + c);

  readln;

end.

3)

var

  a, b, c: real;

 

begin

  writeln('введите числа а и b');

  readln(a, b);

  if a > b then

  begin

    c: = a;

    writeln(c, ' - большее число');

  end;

  if b > a then

  begin

    c: = b;

    writeln(c, ' - большее число');

  end;

  if b = a then writeln('числа равны');

  readln;

end.

 

   

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в python! даны действительные коэффициенты a, b, c, при этом a ! = 0. решите квадратное уравнение ax²+bx+c=0 и выведите все его корни. формат ввода вводятся три действительных числа. формат вывода если уравнение имеет два корня, выведите два корня в порядке возрастания, если один корень — выведите одно число, если нет корней — не выводите ничего. тест 1 входные данные: 1 -1 -2 вывод программы: -1 2 тест 2 входные данные: 1 2 1 вывод программы: -1 тест 3 входные данные: 1 -7.5 3 вывод программы: 0.423966 7.07603
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

гайсанов
Манько_Панферов
Elvira-Natalya
coleslow12
sinicin80
АлександрАлександровна
nord0764
hbqhzwtd
muzeynizhn
palosik7621
fellybrossme
d2904
fetisov68av
abadaeva
fygasika