Nivanova995
?>

Напишите программу, которая выполняет "сжатие массива" – заполняет все копии уже ранее встречавшихся элементов нулями и переставляет все нулевые элементы в конец массива. при этом все оставшиеся элементы располагаются в начале массива в том же порядке, что и в исходном массиве. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. примеры входные данные 6 0 1 2 1 2 3 выходные данные 1 2 3 0 0 0

Информатика

Ответы

helenavalenti2846
Div - это обычное деление нацело, т.е. остаток отбрасывается. а mod - это как раз получение того остатка, который отбрасывается при делении div. пусть х=336, у=8 x div y - это результат деления 336 на 8. делим: 336 / 8 = 42 (разделилось нацело, но если бы и не нацело, все равно отбросили остаток). конструкция x: =x div y - это оператор присваивания. он говорит о том, что надо вычислить все, что находится справа (т.е. после) знака присваивания : = и полученное значение в дальнейшем называть так, как написано до (слева) от этого знака. следовательно, теперь х уже будет равно не 336, а 42. y: =x mod y - снова оператор присваивания. x mod y - это остаток от деления х на у. 42 / 8 = 5 и остаток 2. вот эта двойка и есть результат. теперь у будет равно 2. итого: х=42, у=2
ermisyareg436

program rastirostok;

var h: double; //в  этой переменной храним высоту

var i: integer; // это для счетчика дней

var s: string;

begin

i : = 0;

h: =0.5;

while(h< =32) do

begin

h: = h + 0.4*h;

i: = i+1;

writeln(h: 15: 2);

end;

 

str(i,s);

writeln('количество дней: '+s);

str(h: 15: 2,s);

writeln('высота ростка: '+s);

  end.

в итоге успеет за 13 дней вырасти

расклад по дням и итог

0.70 0.98 1.37 1.92 2.69 3.76 5.27 7.38 10.33 14.46 20.25 28.35 39.69 количество дней: 13 высота ростка: 39.69

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выполняет "сжатие массива" – заполняет все копии уже ранее встречавшихся элементов нулями и переставляет все нулевые элементы в конец массива. при этом все оставшиеся элементы располагаются в начале массива в том же порядке, что и в исходном массиве. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести в одну строчку все элементы получившегося массива, разделив их пробелами. примеры входные данные 6 0 1 2 1 2 3 выходные данные 1 2 3 0 0 0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Kotvitskii
Банова_Елена431
Yurkov
ЕлизаветаВладимирович
Emasterova77
glebovaludok
mira15963256
sveta1864
mb9037479491
Dmitrievna405
Vera-zero281
KonovalovKonstantinovna1306
evge-borisova2
svetlanam81
lazu8375