shangina1997507
?>

Даны 6 чисел. найти максимальное четное число. написать программу с pascal и используя цикл , !

Информатика

Ответы

Yuliya_Viktoriya316

var  a, max, i: integer; begin  repeat    readln(a);     if(a > max) and (a mod 2 = 0) then max : = a;     inc(i);   until(i = 6);   writeln('макс. четное число: ', max); end.

kruttorg

1 задача:

import math

a=int(input())

b=int(input())

if(math.fabs(a+b)>20):

   print(math.pow(a,2))

else:

   b=math.fabs(b)

   print(math.sqrt(b))

---------------------------------------------------------------

2 задача:

a=int(input())

if a == 5:

   print("Отлично")

elif a == 4:

   print("Хорошо")

elif a == 3:

   print("Удовлетворительно")

elif a == 2:

   print("Плохо")

elif a == 1:

   print("Отвратительно")

else:

   print("Это не оценка")

------------------------------------------------------------

3 задача:

x=int(input())

y=int(input())

a=int(input())

b=int(input())

a7 = a%x

b7 = b%y

if(a7>b7):

   print("7A")

else:

   print("7Б")

-------------------------------------------------------------------

4 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<100:

       r=13*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   elif a>100:

       r=math.pow(a,3)-100

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=30-(a/(a-5))

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

-----------------------------------------------------------------------------

5 задача:

import math

print("Введите интервал")

a=int(input())

b=int(input())

while(a<=b):

   if a<4:

       r=3*a-7

       print("X=" + str(a) + " y=" + str(r))

   else:

       r=5*math.pow(a,2)

       print("X=" + str(a) + " y=" + str(r))

   a=a+1

Объяснение:

kotofei147516

#include <iostream>

#include <cmath>

using namespace std;

int main() {

setlocale(LC_ALL,"russian"); // кириллица

cout << "Введите количество сторон: ";

int count; // колво сторон

int kvadrat;  

cin >> count;

count--; // массивы нумеруются с нуля!!!!11!

int sum = 0; // периметр

int question;

if(count==3)

{

cout << "Предположение: Это квадрат? 1 если да и 0 если нет: ";

cin >> question;

if(question!=1)

{

cout << "Вводите стороны по очереди: " << endl;

int a[count]; // стороны в массиве

for(int i = 0; i<=count; i++)

{

cin >> a[i];

sum += a[i];

}

}

else

{

cout << "Введите одну сторону квадрата: ";

cin >> kvadrat;

sum=4*kvadrat;

}

}

else

{

cout << "Вводите стороны по очереди: " << endl;

int a[count]; // стороны в массиве

for(int i = 0; i<=count; i++)

{

cin >> a[i];

sum += a[i];

}

}

cout << "Итого, P = " << sum;

}

Объяснение:

Доп. функция: если 4 стороны, то спрашивает квадрат ли это

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Даны 6 чисел. найти максимальное четное число. написать программу с pascal и используя цикл , !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osnovnoisklad3551
Александровна1973
Oslopova
JisesLove19955
Igor120
moonligh3560
Сергей
choia
Tatianarogozina1306
iivanov54
Klyucharyova
Mbkozlov6
FATEEV
atupicyn754
tershova