mlubov1
?>

Написать программу на pascal для вычисления периметра шестиугольника по заданным координатам его вершин, используя процедуру для нахождения расстояние между двумя точками

Информатика

Ответы

iordanekaterina

к чёрту на куличики

фразеологизм “у черта на куличках” значение

выражение “у черта на куличках”  – начнем с того, что никакого слова кулички в языке нет. от кулича  выйдут куличики, от кулика — кулички. на самом же деле не на кулички надо посылать, а на кулижки. вот тогда справедливость восторжествует, и мы сможем приступить к объяснению этого истинно оборота.кулиги и кулижки были известными и весьма употребительными словами на севере россии. когда хвойный лес «ослабевает», там появляются прогалины, поляны. на них мгновенно начинают расти трава, цветы и ягоды. эти лесные острова и назывались кулигами. еще с языческих времен на кулигах совершались жертвоприношения: жрецы закалывали оленей, овец, телок, жеребцов, все наедались досыта, напивались допьяна.когда же пришло на русь христианство и стало оно теснить язычество, пришел на кулигу крестьянин, поставил избу, стал сеять рожь, ячмень, появлялись целые деревенские артели. когда же жить станови лось теснее, уходили от стариков дети и племянники, да порой так далеко, что и вести достигать переставали, жили, как  у черта на куличках.

другая версия:

 

фразеологизм у черта на куличках  это: страшно далеко, где-то в дикой глуши. общий смысл слов понятен каждому, а вот что такое «кулички», не знает почти никто.

кулички  – испорченное финского корня слово, «кулиги», «кулижки», давно вошедшее в речь. так на севере назывались лесные полянки, лужки, болотца. здесь, в лесистой части страны, поселенцы далекого прошлого все время в лесу «кулижки» – площадки для распашки и покоса.

 

в старых грамотах постоянно встречается такая формула: «и вся та земля, покуда топор ходил и коса ходила». земледельцу часто приходилось на свою ниву отправляться в страшную глушь, на самые дальние «кулижки», хуже ближних разработанные, где, по тогдашним суеверным представлениям, в болотах и буреломах водились и лишние, и черти, и всякая лесная нечисть.

так и получили обычные слова свое второе, переносное значение: далеко, на краю света.

Stefanidi_Semeikina1896

var a: integer;

begin

writeln ('vvedite nomer mesuaca');

read (a);

if (a=1) then writeln ('30');

if (a=2) then writeln ('28');

if (a=3) then writeln ('30');  

  if (a=4) then writeln ('31');  

  if (a=5) then writeln ('30');  

  if (a=6) then writeln ('31');  

  if (a=7) then writeln ('30');  

  if (a=8) then writeln ('31');  

  if (a=9) then writeln ('30');  

  if (a=10) then writeln ('31');  

  if (a=11) then writeln ('30');  

  if (a=12) then writeln ('31');  

end. 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на pascal для вычисления периметра шестиугольника по заданным координатам его вершин, используя процедуру для нахождения расстояние между двумя точками
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

prostopo4ta29
dentinnsmr467
Yurevich1701
stasyan
info126
peresvetoff100015
FATAHOVAMAINA
Nefedova1432
YelenaZOLTANOVICh105
kitoova
saljagindima
andyrvo
Ivan1568
ryazantseva
Shamil