uvarovig
?>

Написать программу которая находит: 1) в последовательности натуральных чисел сумму всех чисел, которые кратны 4 и заканчиваются на цифру 2, кол-во чисел вводит пользователь 2) последовательность заканчивается 0 3)найти кол-во чисел, которые не больше 100 4) подсчитать сумму всей последовательности паскаль abc

Информатика

Ответы

okunevo2010

ответ: 24

Объяснение:

2 бита в двоичной системе дают 4 возможных комбинации. То есть вероятность извлечения белого шара 1/4, то (исходное целое делим на количество комбинаций) . Таким образом, получаем, что всего шаров: белых - одна часть, а чёрных - три. То есть белых шаров в 3 раза меньше: 18 / 3 = 6 (штук) .

А всего шаров:

18 чёрных + 6 белых = 24

или

Пусть в корзине всего x шаров, тогда среди них x-18 белых.

Вероятность того, что из корзины будет вынут белый шар равна P=(x-18)/x

Количество собственной информации равно I=log2(1/P)=log2(1/(x-18)/x))=log2(x/(x-18))

Отсюда

log2(x/(x-18))=2

x/(x-18)=2^2

x=4x-72

x=24 шара

Ignateva737
Pascal: var a: array [1..5] of integer;           i: integer; begin   randomize;   for i: =1 to 5 do        begin             a[i]: =random(31)-15;           write (a[i]: 4);         end;   writeln;   for i: =1 to 5 do       begin           a[i]: =a[i]*2;             write (a[i]: 4);       end;   writeln;   readln; end. c++: #include < iostream> #include < ctime> #include < cstdlib> using namespace std; int main() {     int a[5];     srand (time(null));     for  (int  i = 0; i< 5; i++)     {           a[i] = rand()%15-15;             cout < < a[i] < < " ";       }     cout < < endl;     for (int  i = 0; i< 5;   i++)     {             a[i]*=2;           cout < < a[i] < < " ";       }     return 0; }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая находит: 1) в последовательности натуральных чисел сумму всех чисел, которые кратны 4 и заканчиваются на цифру 2, кол-во чисел вводит пользователь 2) последовательность заканчивается 0 3)найти кол-во чисел, которые не больше 100 4) подсчитать сумму всей последовательности паскаль abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vgolentsova
olimov
Анатольевич447
olyaartemenko
GALINAMTO
Kisuha8465
Овчинников_Грузман
hotnuts
Vyacheslavovna1867
Nugamanova-Tatyana840
airon-082054
Надежда-Андрей930
Fedoseeva
smileystyle
mixtabak2