uses crt;
var
ar: array[1..19]of integer;
i, mul, sum, count, min, mini: integer;
begin
count : = 0;
sum : = 0;
mul : = 1;
randomize;
for i : = 1 to 19 do
begin
ar[i] : = random(13) - 6;
mul : = mul * ar[i];
if(ar[i] mod 2 = 0) then
begin
textbackground(green);
sum : = sum + ar[i];
count : = count + 1;
end;
if(ar[i] = 5) then
textbackground(red);
write(ar[i], ' ');
textbackground(black);
end;
writeln();
writeln('произведение всех элементов массива = ', mul);
writeln('сумма четных чисел = ', sum, ', количество = ', count);
min : = ar[1];
mini : = 1;
write('номера элементов, равных 5: ');
for i : = 1 to 19 do
begin
if(ar[i] = 5) then
write(i, ' ');
if((ar[i]) < min) then
begin
min : = ar[i];
mini : = i;
end;
end;
writeln();
writeln('минимальный элемент = ', min, ', его номер = ', mini);
end.
package nikitauser;
import java.util.Scanner;
public class Class {
public static void main (String[] args) {
System.out.println("Куда Вы предпочитаете пойти?");
try (Scanner scan = new Scanner (System.in)) {
String a = scan.nextLine().toLowerCase();
switch (a)
{
case "налево":
System.out.println("Налево пойдёшь - себя потеряешь, коня !");
break;
case "направо":
System.out.println("Направо пойдёшь - коня потеряешь, себя !");
break;
case "прямо":
System.out.println("Прямо пойдёшь - и себя, и коня потеряешь!");
break;
default:
System.out.println("Варианты ответа:\nналево\nнаправо\nпрямо");
break;
//программа написана на Java 16. Варианты ответов могут быть разными - зависит от сказки ( данная строка - комментарий; можете просто удалить)
} } } }
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая задает трехмерный массив и находит в нем наибольшее число. ( pascal буду рад, если прокомментируете, хочу разобраться.
const
n = 3;
var
a: array[1..n, 1..n, 1..n] of integer; //объявляем трехмерный массив размерности n x n x n
i, j, k, max: integer;
begin
randomize;
max : = -maxint - 1; {присваисваем maxrcbvfkmyjve 'ktvtyne минимальное возможное значения типа integer}
for i : = 1 to n do { с трех циклов проходим по всем элементам массива, чобственно тоже самое что и с двумерным массивом только еще 1 цикл}
begin
writeln;
writeln('i = ', i); {выводм производится в виде нескольких квадратных матриц тут указывается номер каждой квадратной матрицы}
for j : = 1 to n do
begin
for k : = 1 to n do
begin
a[i, j, k] : = random(21) - 10; // генерируем случайное значение от -10 до 10
if a[i, j, k] > max then { если больше текущего максимального то станвится новым максимальным}
max : = a[i, j, k];
write(a[i, j, k]: 4); //выводим элемент массива
end;
writeln;
end;
end;
writeln('максимальный элемент массива равен ', max);
end.