ibird777
?>

Мне решить эти . контрольная работа №4 по теме < > 8 класс (босова) вариант 11. составьте линейную программу нахождения остатка и целой части от деления двух натуральных чисел, введённых с клавиатуры, если известно, что числа не превышают 5000. вывод ответа осуществить в 1 строку. числа не должны быть написаны слитно.замечание: известно, что можно вводить только натуральные числа.2. составьте программу, которая позволяет вводить (2 - решил полностью, 1 - решил с ошибками, 0 - не решил) за каждое этой контрольной работы. если их сумма больше 3, то вывести < > , иначе < > .3. составьте программу, которая считает, сколько натуральных чисел до 50 кратны 3.

Информатика

Ответы

antonkovalev89

ответ:

1)

var a,b: integer;

begin

read(a,b);

write((a mod b)+' '+(a div b));

end.

2)

var a,b,c: integer;

begin

read(a,b,c);

if a+b+c> 3 then write('< > ')

else write('< > ');

end.

3)

var i,count: integer;

begin

for i: =1 to 50 do

if (i mod 3) =0 then

count: =count +1;

write(count);

end.

Геннадьевна Вета560
Pascalabc.net 3.3.5, сборка 1662 от 29.04.2018 внимание! если программа не работает, обновите версию! 1) понятно, что первое такое число - это -3. а дальше - через begin   range(-3,-21,-3).println end. результат -3 -6 -9 -12 -15 -18 -21 2) первое четное положительное - это 2. и через два begin   var n: =2;   while n< =20 do begin       write(n,' ');       n+=2       end;   writeln end. результат 2 4 6 8 10 12 14 16 18 20
Zezyulinskii Fedor

для того, чтобы решить данную , необходимо воспользоваться формулой  n = 2^i, где n - максимальное количество цветов в палитре, а i - глубина цвета.

2^8 < 312 < 2^9 

если мы будем использовать глубину цвета равную 8 битам, то максимальное допустимое количество цветов в палитре будет равняться 256 (так как 2^8 = 256), что не удовлетворяет условиям .

значит, нам необходимо использовать глубину цвета равную 9 битам, так как при этом значении  максимальное допустимое количество цветов в палитре будет равняться 512(так как 2^9 = 512), а значит для кодирования 312 цветов памяти хватит с избытком.

ответ: 9 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Мне решить эти . контрольная работа №4 по теме < > 8 класс (босова) вариант 11. составьте линейную программу нахождения остатка и целой части от деления двух натуральных чисел, введённых с клавиатуры, если известно, что числа не превышают 5000. вывод ответа осуществить в 1 строку. числа не должны быть написаны слитно.замечание: известно, что можно вводить только натуральные числа.2. составьте программу, которая позволяет вводить (2 - решил полностью, 1 - решил с ошибками, 0 - не решил) за каждое этой контрольной работы. если их сумма больше 3, то вывести < > , иначе < > .3. составьте программу, которая считает, сколько натуральных чисел до 50 кратны 3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Алина Ракитин1730
and-syr
utkinslava
andreyshulgin835
porotikova1004
Korneeva1856
Сергеевич1726
prettymarina2015
cvetyzelen283
marinaled8187
lbeglarova6
gabbro19975650
innaglobal21
ВалерийАндреевна1788
mixtabak2