vitbond12
?>

Составьте программу закрашивания указанных клеток с использованием цикла для.​

Информатика

Ответы

shpakohat
Пусть k(n) - количество звездочек, напечатанных при вызове f(n) тогда k(n) = 1 { writeln('*') } + k(n-2) {вызов f(n-2) -> печатается еще k(n-2) звездочек} + k(n div 2) {f(n div 2)} при n > 0 и k(n) = 1 при n < = 0 требуется найти k(7) k(7) = 1 + k(5) + k(3) k(5) = 1 + k(3) + k(2) k(3) = 1 + k(1) + k(1) k(2) = 1 + k(0) + k(1) k(1) = 1 + k(-1) + k(0) k(0) = k(-1) = 1 {0, -1 < = 0} k(1) = 1 + 1 + 1 = 3 k(2) = 1 + 1 + 3 = 5 k(3) = 1 + 3 + 3 = 7 k(5) = 1 + 7 + 5 = 13 k(7) = 1 + 13 + 7 = 21 ответ: 21
irschacha
Var a, b, c, d: integer; p: integer; begin writeln('введите первое число: '); readln(a); writeln('введите второе число: '); readln(b); writeln('введите третье число: '); readln(c); writeln('введите четвёртое число: '); readln(d); if a> b then writeln('1 число больше 2'); if a< b then writeln('1 меньше 2'); if b> c then writeln('2 число больше 3'); if b< c then writeln('2 меньше 3'); if c> d then writeln('3 число больше 4'); if c< d then writeln('3 меньше 4'); if c> d then writeln('4 число больше 1'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу закрашивания указанных клеток с использованием цикла для.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Станиславович1830
asvirskiy26
hadzievamareta44
burylin9
nuralievelsh
nat5555
kuharhuks
nkaminskaja
dksvetlydir
Shamsulo
cometa94558
blackpoint2020273
egorov
ryazantseva
Марина566