rastockin8410
?>

Напишите программу формирования одновременного массива данных a из 10 целочисленных элементов , лежащих в интервале от -10 до 10 и массива b который будет заполнен индексами четных элементов массива a

Информатика

Ответы

myrisik2490

program fibonachinums;

function fibn(n: integer): biginteger;

begin

  var (f1, f2) : = (biginteger(1), biginteger(1));

  for var i : = 3 to n do

    (f1, f2) : = (f2, f1 + f2);

  result : = f2;

end;

function fibsumn(n: integer): biginteger;

begin

  var (f1, f2) : = (biginteger(1), biginteger(1));

  var sum: biginteger;

 

  if n = 0 then sum : = 0

  else sum : = 1;

 

  for var i : = 2 to n do

  begin

    (f1, f2) : = (f2, f1 + f2);

    sum += f1;

  end;

 

  result : = sum

end;

begin

  println('десятое число фибоначчи: ',fibn(10));

 

  var n : = 100;

  writeln($'{n}-е число фибоначчи: ',fibn(n));

 

  println($'сумма первых {n} чисел фибоначчи: ',fibsumn(n))

 

end.

Aleksandr768

1. #include < stdio.h>

int main(void)

{

unsigned int hours;

scanf("%u", & hours);

if(hours > = 0 & & hours < 6)

  printf("ночь.");

else if(hours > = 6 & & hours < 12)

  printf("утро.");

else if(hours > = 12 & & hours < 18)

  printf("день.");

else if(hours > = 18 & & hours < 0)

  printf("вечер.");

return 0;

}

2. #include < stdio.h>

#include < stdlib.h>

#include < time.h>

int main(void)

{

unsigned int

  chance = 3, enter;

srand(time(null));

while(chance > 0)

{

  printf("вы загадали число %d? 1 - да, 0 - нет\n", rand() % 5 + 1);

  scanf("%u", & enter);

  if(enter == 1)

  {

  printf("! \n");

  break;

  }

  printf("жаль : (\n");

  chance--;

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу формирования одновременного массива данных a из 10 целочисленных элементов , лежащих в интервале от -10 до 10 и массива b который будет заполнен индексами четных элементов массива a
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

proporcia46
deadnobody
Andrei_Mariya
miha23727
mekap22044
DJXEz80
nanasergevn
vmnk38
ЕленаГерасимова
mushatolga
Галина-Юлия1292
mulyugina365
lirene
Vladimirovna1997
Valentinovna