Андреевич-Екатерина1974
?>

Стестами по ! а1. определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 3*4; b : = (a div 10) + 4; a : = (b mod 10) + 2; b: = a + b; a: = a mod 2 + b div 3; 1) a=4, b=14; 2) a= 24, b= 6; 3) a=5, b=12; 4) a=8, b=12. а2. для какого из указанных значений числа x истинно высказывание ((x < 5)→(x < 3)) ù ((x < 2)→(x < 1)) 1) 1 2) 2 3) 3 4) 4 а3. укажите, какое логическое выражение равносильно выражению ¬(a ú ¬b ú c) ? 1) ¬a ú b ú ¬c 2) a ù ¬b ù c 3) ¬a ú ¬b ú ¬c 4) ¬a ù b ù ¬c x y z f 1 1 1 1 1 1 0 1 1 0 1 1 а4.символом f обозначено одно из указанных ниже логических выражений от трех аргументов: x, y, z. дан фрагмент таблицы истинности выражения f (см. таблицу справа какое выражение соответствует f? 1) x ú ¬y ú z 2) x ù y ù z 3) x ù y ù ¬z 4) ¬x ú y ú ¬z а5.что будет выведено на печать в результате выполнения следующих операторов: a : = 5; b : = 10; write( 'суммадвухчисел ' ); write( 'a+b' ); write( ' = ', a+b ); 1) сумма двух чисел 5+10 = 15 2) сумма двух чисел a+b = 15 3) сумма двух чисел 5+10 = a+b 4) сумма двух чисел a+b = 5+10 5) ни один из ответов 1-4 не верен а6. чему было равно значение переменной a, если после выполнения операций b : = sqrt( sqr(a+1) ); c : = -b; a : = 1 + 2 / (c-b); она стала равна 0 ? 1) 2 2) 0 3) –1 4) любое вещ. число, не равное -1 5) ни один из ответов 1-4 не верен а7. чему будет равно значение а после выполнения цикла а: =1024; while a> 0 do a: =a / 2; 1) 0 2) 1 3) зациклится 4) 512 5) ни один из ответов 1-4 не верен a8. сколько раз выполнится тело цикла? a: =32; while a> 2 do begin a: =a / 2; writeln(‘a’); end; 1) 8 2) 6 3) 5 4) 4 5) 3

Информатика

Ответы

Veril8626

1) 3

5) 2

6) 5

7) 5

8) 4

остальное не понятно

Васильевич Валерьевна

значит просто расписать как это должно работать?

объявляем переменную день, которая будет считывать количество дней.

вводится h хлеба - общее количество и z - количество, которое потребляется в день.

переведем кг в г, чтобы легче было считать: h = h * 1000

запускается цикл пока h > 0(пока хлеб вообще имеется)

один проход цикла - один день, значит в теле цикла h = h - z

то есть мы вычитаем из общего кг хлеба суточное потребление.

и увеличиваем переменую день на 1.

после этого цикла выводим переменную день.

пример на языке с++. в случае ввода h = 1, z = 50, выводится ответ 20 дней

#include < iostream>

#include < cstdlib>

using namespace std;

int main()

{

int day = 0, z, n;

cin > > n > > z;

n = n * 1000;

while(n > 0){

  n = n - z;

  day++;

}

cout < < day < < endl;

system("pause");

return 0;

}

Наталья286
Из условия нам известно, что ввод завершается числом ноль. информация о количестве чисел требуется только если их запоминать в массиве, но у нас однопроходный алгоритм, массив не нужен, поэтому про "1000 чисел" благополучно забываем. числа целые, и по модулю не превышают 30 000, следовательно им надо отводить двухбайтный тип integer, в в котором диапазон представления чисел [-32 768 ; 32 767]."нечетные числа, кратные трем" - это такие, у которых остаток от деления на два ненулевой, а остаток от деления на три нулевой. поскольку числа целые, то и деление, конечно же, целочисленное.длина последовательности n - это просто счетчик количества прохождений цикла за вычетом единицы, потому что последний проход по циклу будет при вводе нуля, а его учитывать не надо. в другом счетчике k мы накапливаем количество чисел, для которых выполнилось рассмотренное выше условие "нечетные числа, кратные трем".var   n,k,m: integer; begin   writeln('вводите целые числа, для окончания введите 0');   n: =0; k: =0;   repeat       read(m); inc(n);       if (m mod 2 < > 0) and (m mod 3 = 0) then inc(k)   until m=0;   writeln('введено чисел- ',n-1);   writeln('нечетных, кратных трем- ',k) end. тестовое решение: вводите целые числа, для окончания введите 0 -5 12 8 27 -18 14 -33 7 0 введено чисел- 8 нечетных, кратных трем- 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Стестами по ! а1. определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 3*4; b : = (a div 10) + 4; a : = (b mod 10) + 2; b: = a + b; a: = a mod 2 + b div 3; 1) a=4, b=14; 2) a= 24, b= 6; 3) a=5, b=12; 4) a=8, b=12. а2. для какого из указанных значений числа x истинно высказывание ((x < 5)→(x < 3)) ù ((x < 2)→(x < 1)) 1) 1 2) 2 3) 3 4) 4 а3. укажите, какое логическое выражение равносильно выражению ¬(a ú ¬b ú c) ? 1) ¬a ú b ú ¬c 2) a ù ¬b ù c 3) ¬a ú ¬b ú ¬c 4) ¬a ù b ù ¬c x y z f 1 1 1 1 1 1 0 1 1 0 1 1 а4.символом f обозначено одно из указанных ниже логических выражений от трех аргументов: x, y, z. дан фрагмент таблицы истинности выражения f (см. таблицу справа какое выражение соответствует f? 1) x ú ¬y ú z 2) x ù y ù z 3) x ù y ù ¬z 4) ¬x ú y ú ¬z а5.что будет выведено на печать в результате выполнения следующих операторов: a : = 5; b : = 10; write( 'суммадвухчисел ' ); write( 'a+b' ); write( ' = ', a+b ); 1) сумма двух чисел 5+10 = 15 2) сумма двух чисел a+b = 15 3) сумма двух чисел 5+10 = a+b 4) сумма двух чисел a+b = 5+10 5) ни один из ответов 1-4 не верен а6. чему было равно значение переменной a, если после выполнения операций b : = sqrt( sqr(a+1) ); c : = -b; a : = 1 + 2 / (c-b); она стала равна 0 ? 1) 2 2) 0 3) –1 4) любое вещ. число, не равное -1 5) ни один из ответов 1-4 не верен а7. чему будет равно значение а после выполнения цикла а: =1024; while a> 0 do a: =a / 2; 1) 0 2) 1 3) зациклится 4) 512 5) ни один из ответов 1-4 не верен a8. сколько раз выполнится тело цикла? a: =32; while a> 2 do begin a: =a / 2; writeln(‘a’); end; 1) 8 2) 6 3) 5 4) 4 5) 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yevgeniya1807
maksimovskiy7657
Даниил247
vadim330
semenovakotya577
Ivanovich_Kostik898
Ludmila777020
xalina85
vladimirdoguzov
gulyaizmailova
info292
Дил1779
Олег1105
magnit-expo