ответ:
maxn = индекс макс значения в массиве , minn - миним индекс массива
через if мы по этапно сравниваем значения , если условия верны то , значения min/max меняется на текущее значения массива
объяснение:
program d;
var min,max,i,minn,maxn : integer;
mas: array[0..4] of integer;
begin
for i: =0 to 4 do
begin
readln(mas[i]);
end;
min: =mas[0];
minn: =1;
maxn: =1;
max: =mas[0];
for i: =1 to 4 do
begin
if min
if max> mas[i] then begin maxn: =i; max: =mas[i] end;
end;
mas[maxn]: =min;
mas[minn]: =max;
for i: =0 to 4 do
writeln(mas[i]);
end.
Поделитесь своими знаниями, ответьте на вопрос:
На паскале составить программу нахождения наибольшего общего делителя трех чисел , испол. след. формулу: нод(а, в, с)=нод(нод(а, в), с)
function nod (x,y: longint): longint; beginif x=0 then nod: =yelseif y=0 then nod: =xelseif x> y then nod: =nod(x mod y,y)elsenod: =nod(x,y mod x); end;
vara,b,c: longint; beginread(a,b,c); writeln('nod (',a,',',b,',',c,') = ',nod(nod(a,b),c)); end.