svetasvetlana429
?>

)даны радиус круга и сторона квадрата написать программу определяющую у какой фигуры площадь больше?

Информатика

Ответы

diana8

program ololo;

var a, b, s1, s2: real;

begin

writeln("введите радиус круга");

readln(a);

s1: =3.14*a*a;

writeln("введите сторону квадрата");

read(b);

s2: =b*b;

if s1> s2 then write("площадь круга больше") else if s2> s1 then write("площадь квадрата больше") else write("площади равны");

end.

denis302007
Подробно допишешь сам, чтобы было красиво читаемо 1. когда цикл находится внутри цикла 2. самый первый исполняемый цикл(внутри которого есть ещё циклы или цикл). 3. то что внутри внешнего цикла. 4. вот смотри, внешний цикл(например - for) начинает работу, представим что у внешнего цикла переменная-счётчик i, а у внутреннего j. первая итерация i = 1 и начинается работа внутруннего цикла и счетчик j проходится от 1 до 10(почему 10? ну просто я захотел, это количество итерации которое должно выполнить цикл) и это всего одна итерация внешнего цикла, в тот момент когда внутренний выполнился полностью(в зависимости от количества итерации внешнего цикла будет зависеть сколько раз будет выполнятся внутренний цикл)
elena-novikova-1992
1. // pascalabc.net 3.3 begin   var a: =arrrandom(20,10,90); a.println;   var max_1: =a.max;   writeln('max_1 = ',max_1,' i_max_1 = ',a.indexmax+1);   var max_2: =a.where(x-> x< > max_1).max;   writeln('max_2 = ',max_2,' i_max_2 = ',a.indexof(max_2)+1); end. пример: 58 10 76 12 22 38 63 30 16 81 84 58 65 20 29 31 18 83 12 38 max_1 = 84 i_max_1 = 11 max_2 = 83 i_max_2 = 18 2. // pascalabc.net 3.3 begin   var a: =arrrandom(20,10,90); a.println;   var sr: =a.average;   writeln('среднее = ',sr);   var m: =a.minby(x-> abs(x-sr));   writeln('искомый номер = ',a.indexof(m)+1); end. пример: 74 80 55 12 74 49 86 32 34 68 29 82 14 35 15 81 18 63 38 75 среднее = 50.7 искомый номер = 6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

)даны радиус круга и сторона квадрата написать программу определяющую у какой фигуры площадь больше?
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ГегамБукреев830
fixer2006
Pavlushina-Novikova
aleksandramir90
Klyucharyova
okarp
olgalooo
ninaandreeva3179
shajmasha
potapin
amramzi
sabinina0578
Sharap
Курнев-Анастасия359
adman7
▲