Составить программу на языке с. как можно проще, используя массив. : дана матрица c размером 3х4, составить программу для подсчета количества четных элементов в каждой строке матрицы с их запоминанием.
#include < iostream> #include < string> typedef std: : string str; str reacttomark(); int main() { str mark = reacttomark(); std: : cout < < mark < < '\n'; return 0; } str reacttomark() { int mark; std: : cout < < "оценка: "; std: : cin > > mark; switch (mark) { case 1: return " плохо, надо мне прийти в школу"; case 2: return "плохо, я тобой недовольна"; case 3: return "мог бы и лучше"; case 4: return "хорошо, но пятёрка лучше"; case 5: return "молодец, на выходных пойдёшь в кино"; default: std: : cout < < ", введи правильную оценку! " < < '\n'; return reacttomark(); } }
argo951385
24.06.2022
Const n = 5; var p: array[1..n] of integer; c,i,j,b: integer; begin writeln('введите пять целых чисел'); for i: =1 to n do begin repeat b: =0; read(c); for j: = 1 to i-1 do if p[j] = c then b: =j; if b > 0 then writeln('число ',p[b],' уже было'#13'попробуйте ещё раз') else p[i]: =c; until b = 0; end; writeln('полученная последовательность'); for i: = 1 to n do write(p[i],' ') end.