Александр Джабраиловна1967
?>

Написать программу на паскале "ввести число от 0 до 24 и вывести фразу «доброе утро», «добрый день», «добрый вечер», «спокойной ночи» в зависимости от времени суток. пример: введите число от 0 до 24: 12 добрый день! "

Информатика

Ответы

Юрьевич293

uses crt; var day: integer; beginwriteln(day); if (day > 0) and (day < 25) thencase day of

0: writeln('good night! '); ; 1: writeln('good night! '); ; 2: writeln('good night! '); ; 3: writeln('good night! '); ; 4: writeln('good morning! '); ;

24: writeln('good night! '); end.

 

дальше доделай сам

rabchek145200614
Интересная , var x,i,c,q,p: integer; s: string; max,min,k: char; begin   readln(x);   str(x,s);   max: =s[1];   min: =s[1];   p: =1; q: =1;   for i: =2 to length(s) do     begin     if s[i]> max then       begin         max: =s[i];         q: =i;       end;     if s[i]< min then       begin         min: =s[i];         p: =i;       end;     end;   k: =s[p];   s[p]: =s[q];   s[q]: =k;   val(s,x,c);   writeln(x); end. сработает для чисел любой значности.
kgrechin
Переливание решение ! ! решите мне следующие с решением!   переливание!   1. можно ли, пользуясь 9- и 12-литровыми , отмерить воду в количестве: а) 6 л; б) 4 л?   2. как, пользуясь емкостями 7 л и 12 л, получить 1 л воды?   3. в первый сосуд вмещается 9 л воды, во второй 5 л, а в третий – 3 л. первый сосуд наполнен водой, а остальные – пусты. как с их отлить: а) 1 л воды; б) 7 л воды?   4. бидон емкостью 10 л наполнен молоком. требуется перелить из этого бидона 5 л в 7-литровый бидон, используя при этом еще один, 3-литровый. как это сделать?   5. в бочке 18 л бензина. имеется два ведра по 7 л, в которые нужно на-лить по 6 л бензина, и черпак, объем которого равен 4 л. как можно осуществить разлив?   7. как с двух сосудов емкостями 7 л и 4 л разделить поровну молоко, находящееся в 12-литровом бидоне?   8. можно ли с двух сосудов емкостями 9 л и 11 л набрать из крана 10 л воды?   9. в один стакан налито 5 ложек чая, а в другой – 5 ложек молока. ложку молока перелили из второго стакана в первый, затем тщательно все перемешали и ложку чая с молоком перелили обратно во второй стакан. чего оказалось больше: чая во втором стакане или молока – в первом?   10. имеется три сосуда без делений объемами 4 л, 5 л, 6 л, кран с водой, раковина и 4 л сиропа в самом маленьком сосуде. можно ли с переливаний получить 8 л смеси воды с сиропом, так чтобы в каждом сосуде воды и сиропа было поровну?   11. как разделить поровну между двумя семьями 12 литров хлебного кваса, находящегося в двенадцатилитровом сосуде, воспользовавшись для этого двумя пустыми : 8-литровым и 3-литровым?   12. у карлсона есть ведро варенья, оно вмещает 7 литров. у него есть 2 пустых ведерка - 4-литровое и 3-литровое. карлсону отлить 1 литр варенья к чаю в меньшее (3-литровое) ведерко, оставив 6 литров в большом (7-литровом) ведре.  13. летом винни пух сделал запас меда на зиму и решил разделить его пополам, чтобы съесть половину до нового года, а другую половину - после нового года. весь мед находится в ведре, которое вмещает 6 литров, у него есть 2 пустые банки - 5-литровая и 1-литровая. может ли он разделить мед так, как задумал?   14. на другой год винни пух запасся 10 литрами меда. под руками у него два ведра - 7-литровое и 4-литровое. как ему разделить мед пополам?   15. для разведения картофельного пюре быстрого приготовления "зеленый великан" требуется 1 л воды. как, имея два сосуда емкостью 5 и 9 литров, налить 1 литр воды из водопроводного крана?   16. для марш-броска по пустыне путешественнику необходимо иметь 4 литра воды. больше он взять не может. на базе, где имеется источник воды, только 5-литровые фляги, а также имеются 3-литровые банки. как с одной фляги и одной банки набрать 4 литра во флягу?

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале "ввести число от 0 до 24 и вывести фразу «доброе утро», «добрый день», «добрый вечер», «спокойной ночи» в зависимости от времени суток. пример: введите число от 0 до 24: 12 добрый день! "
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vtarasyuk
ortopediya
Reutskii-Kirilovskii1625
Маргарита1091
seletan1
moskvabelarus
prohorovalena
deshkina82
Alenachernika9111
arturusinsk5
superkiosk249
ea-office
Владимир
alex13izmailov
Zibuxin3