plio67380
?>

Вмассиве из 10 чисел есть положительные и отрицательные элементы.вычислить сумму отрицательных элементов масива. составить программу на языке паскаль и блок-схему.заранее )

Информатика

Ответы

tkozina

program seleone; const n=10; var a: array[1..n] of integer;   sum, i: integer; begin  writeln('*** alphaues is ***');   sum: =0;   for i: =1 to n do  begin      write('введите ',i,'-e число ');       readln(a[i]);       if a[i] < 0 then sum : = sum + a[i];   end;   writeln('сумма отрицательных элементов равна ',sum); end.

simplexsol

начнем сначала:

определим объем одного символа.

256 символов соответстуют одному байту информации (или 8 битам). количество бит можно посчитать по формуле log (256) по основанию 2. он равен 8.

 

значит один символ - это один байт. теперь посмотрим какой объем информации содержит страница: 30*70 = 2100 байт.

всего у нас есть 5 страниц текста:

2100 байт * 5 = 10500 байт информации.

 

по современной классификации это 10.5 килобайт информации.

по старой классификации (изучают в школах) это примерно 10.25 килобайт информации 

dlydesertov1

алфавит - это счетное множество.

мощностью такого множества называется количество элементов этого множества.

 

в настоящее время термин килобайт не однозначен. возьмем прошлое его значение (наверняка сейчас так и есть в школьной программе)

1 килобайт = 1024 байта.

 

итого:

у нас 256*2 = 512 символов, которые занимают 1024/16 = 64 байта.

 

таким образом   один символ занимает 64/512   = 1/8 байта или один бит. (в каждом байте ровно 8 бит).

 

один бит информации это нолик или единичка. то есть имеет всего два значения. 

это и есть ответ к :

мощность алфавита: 2 

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вмассиве из 10 чисел есть положительные и отрицательные элементы.вычислить сумму отрицательных элементов масива. составить программу на языке паскаль и блок-схему.заранее )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bulanova
Chopper-hinter25
zimbickij19
Матфеопуло1006
Ter-Pogosov_Vasilevna
markitandl
yurievaalxndra55
alfastore4
manager-3
delta88
Федорович Шахова241
office
Mexx9050
kristi-a-90
janetp