Sidorenko
?>

Прошу . напишите программу нахождения среднего арифметического 3-х целых чисел, вводимых с клавиатуры.

Информатика

Ответы

skvik71672

var a,b,c: integer; s: real; beginwriteln('vvedite abc'); read(a,b,c); s: =(a+b+c)/3; writeln('srednee arifmeticheskoe 3 chisel = ',s); end.

yuliasam
#include < stdio.h> #include < math.h> struct prm {     float a, b, c; };   struct tch {     float x, y; };   void peres2(struct prm a, struct prm b, struct tch *t) {     t-> x = (b.c*a.b-a.c*b.b)/(a.a*b.b-a.b*b.a);     t-> y = (b.a*a.c-a.a*b.c)/(a.a*b.b-a.b*b.a); }   int prov(struct prm a, struct prm b) {     return a.a*b.b-a.b*b.a! =0; }   void vvod(struct prm *a, int k) {     do {         printf("введите коэффициенты прямой %i\n", k);         scanf("%f%f%f", & a-> a, & a-> b, & a-> c);         if ((a-> a == 0) & & (a-> b == 0))             printf("это не прямая, повторите ввод\n");     } while ((a-> a == 0) & & (a-> b == 0));     a-> c = -a-> c; }   struct prm a, b, c; struct tch m12, m13, m23; float s;   int main() {     vvod(& a, 1);     vvod(& b, 2);     vvod(& c, 3);     if (! prov(a, b) || ! prov(a, c) || ! prov(b, c)) {         printf("прямые попарно не пересекаются");         return 0;     }     peres2(a,b,& m12);     peres2(a,c,& m13);     peres2(b,c,& m23);       printf("точка пересечения 1-2: %5.2f; %5.2f\n", m12.x, m12.y);     printf("точка пересечения 1-3: %5.2f; %5.2f\n", m13.x, m13.y);     printf("точка пересечения 2-3: %5.2f; %5.2f\n", m23.x, m23.y);       s = fabs(m12.x*(m23.y-m13.y)+m23.x*(m13.y-m12.y)+m13.x*(m13.y-m23.y))/2;     printf("площадь треугольника пересечений=%.2f", s);     return 0; }
German
< ! doctype html> < html> < head>       < title> страница< /title> < /head> < body> < h1> заголовок< /h1> < hr> < ul >       < li> элемент списка 1< /li>       < li> элемент списка 2< /li>       < li> элемент списка 3< /li> < /ul> < img src="путь к картинке"> < a href="#"> ссылка< /a> < /body> < /html>

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Прошу . напишите программу нахождения среднего арифметического 3-х целых чисел, вводимых с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yuliyastatsenko3894
Popova838
eliteclassic308
Vladimirovna Yevtodeva
deadnobody
olegtarasov1965
Oksana373
sjmurko
smakejkina
akakne86
Лихачев Полина1978
Yelizaveta555
Бунеева
kuznecovav3066
volkovaoksana19806037