Yelena1409
?>

Решить информатика-паскаль(програмирование) дано целое положительное четырехзначнгое число.напишите программу, позволяющую определить сумму двух первых цифр заданного четырехзначного числа.например 1234 - 3

Информатика

Ответы

Оздоевский

var n,s: integer; x1,x2: integer; beginwrite('vvedite n = '); read(n); x1: =n div 1000; x2: =n mod 1000 div 100; s: =x1+x2; writeln(s); end.

marver201040

Pascal

const

 nmax = 100;

var

 a: array [1..nmax, 1..nmax] of integer;

 i, j: byte;

 n, max, max1: integer;

begin

 randomize;

 Writeln('Введите размер матрицы: ');

 Read(n);

 for i := 1 to n do

 begin

   for j := 1 to n do

   begin

     a[i, j] := Random(-10, 10);

     Write(a[i, j]:5);

   end;

   Writeln;

 end;

 Writeln;

 Max := A[1, 1];

 Max1 := 1;

 for i := 2 to n do

 begin

   for j := 2 to n do

     if (i = j) then

       if a[i, j] > max then max := a[i, j];

   if a[i, n - i + 1] > a[max1, n - max1 + 1] then max1 := i;

 end;

 Writeln('Максимальный элемент главной диагонали: ', max);

 writeln('Максимальный элемент побочной диагонали: ', a[max1, n - max1 + 1]);

end.

Тестовое решение:

Введите размер матрицы:  

5

   6   -2  -10   -9   -6

   2   -2   -8   -7    7

  -5   -8    4    2    3

   4    6    6    2    2

   6    7   -3   -9   -2

Максимальный элемент главной диагонали: 6

Максимальный элемент побочной диагонали: 6

const

 nmax = 50;

var

 a: array [1..nmax] of real;

 b: array [1..nmax] of real;

 c: array [1..nmax] of real;

 i, n: integer;

begin

 writeln('Введите размер массива: ');

 Read(n);

 for i := 1 to n do

 begin

   a[i] := Random(-20, 20); end;

 for i := 1 to n do

 begin

   if a[i] > 0 then b[i] := a[i] else c[i] := a[i];

 end;

 writeln('Исходный массив');

 for i := 1 to n do

 begin

   write(a[i], ' '); end;

 Writeln;

 writeln('Массив положительных');

 for i := 1 to n do

 begin

   write(b[i], ' '); end;

 Writeln;

 writeln('Масив отрицательных');

 for i := 1 to n do

 begin

   write(c[i], ' '); end;

end.

Тестовое решение:

Введите размер массива:  

10

Исходный массив

19 -1 16 -13 -6 -7 -17 13 18 19  

Массив положительных

19 0 16 0 0 0 0 13 18 19  

Масив отрицательных

0 -1 0 -13 -6 -7 -17 0 0 0

Anatolevich_Kulikov1229

var

 a: array [1..20, 1..20] of integer;

 b: array [1..100] of integer;

 m, n, k, i, j: integer;

begin

 k := 0;

 Writeln('Введите количество строк в массиве'); Readln(n);

 Write('Введите количество столбцов в матрице'); Readln(m);

 for i := 1 to n do

   for j := 1 to m do

   begin

     Write('Введите а[', i, ',', j, ']=');

     Readln(a[i, j])

   end;

   Writeln('Новый массив');

 for i := 1 to n do

   for j := 1 to m do

     if a[i, j] > 4 Then begin

       b[i] := a[i, j];

       Write(b[i], ' ');

     end;

end.

Тестовое решение

Введите количество строк в массиве

3

Введите количество столбцов в матрице3

Введите а[1,1]=4

Введите а[1,2]=6

Введите а[1,3]=7

Введите а[2,1]=0

Введите а[2,2]=2

Введите а[2,3]=6

Введите а[3,1]=5

Введите а[3,2]=4

Введите а[3,3]=3

Новый массив

6 7 6 5

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить информатика-паскаль(програмирование) дано целое положительное четырехзначнгое число.напишите программу, позволяющую определить сумму двух первых цифр заданного четырехзначного числа.например 1234 - 3
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

unalone5593
sev-94428
Shaubnatali
YuREVICh646
anazarov80
helenya
bereza81
karkh267
Мартынова1638
Кирилл-Морозова
nanasergevn
sveremeev816
ilysozkn27
nchalov2
Vlad Petr531