program ilnur17; uses crt; var n,sum,temp: integer; begin write('введите число '); readln(n); if n< > 0 then begin sum: =0; writeln('*** alphaues is ***'); writeln('*** ok ***'); while n> =1 do begin write('введите следующее число '); readln(temp); if (temp< 0) and (temp mod 2 = 0 ) then sum : = sum + temp; n: =n-1 end; end else writeln('вы ввели 0 - выход из программы'); writeln('cуммa отрицательных четных чисел равна ',sum); end.
ответ: Кратко:
Персональный компьютер, ПК — компьютер, предназначенный для эксплуатации одним пользователем, то есть для личного использования.
У персонального компьютера есть два важных преимущества по сравнению со всеми другими видами компьютеров: он имеет относительно простое управление и может решать достаточно широкий класс задач. В англоязычных источниках ПК звучит как Personal Computer и имеет сокращение PC. В России можно встретить и другое название ПЭВМ – это Персональная Электронно-вычислительная машина. Таким образом, ПК является вычислительной машиной, служащей для работы, доступа и использования возможности сетей; это платформа для игр и мультимедийных возможностей.
please please please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please pleaseplease please please please please please please please please please please please please please please please please please please please please please please please please please please please please please
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая суммирует n отрицательных четных чисел из вводимых с клавиатуры чисел, при вводе n=0 выход из программы.
cls
b:
input n
if n< 0 or int(n)< > n then goto b
if n=0 then end
dim a(n)
for i = 1 to n
a:
input a(n)
if a(n) > = 0 or int (a(n)/2)< > (a(n)/2) then goto a
s=s+a(n)
next i
print s