Salkinserg
?>

Напишите самый простой вариант, без массивов с цикла! (первый год изучения паскаля) напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность) . количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: разность максимального и минимального чисел.

Информатика

Ответы

docvet4

program juliavanina; uses crt; var  r,min,max: real;   k: integer; begin  writeln('*** alphaues is ***');   writeln('***                  ok                        ***');   min: =0;   max: =0;   k: =0;   r: =1;   writeln('введите ненулевое число, не превышающее 30000 по модулю');   writeln('(или введите 0 для конца последовательности) ');   while (r< > 0) and (k< 1000) do      begin          write('ввод: ');             readln (r);           if abs(r)< 30000 then                  begin                      if min> r then min: =r;                       if max< r then max: =r;                       k: =k+1;                     end              else                  begin                      writeln ('вы ввели слишком большое по модулю число');                       writeln ('это число не будет учтено');                   end;       end;   writeln();   writeln('всего введено ',k-1,' чисел');   writeln('разность min и max составляет ',max-min); end.

 

проверено - работает на паскаль авс

vikashop269

Написать программу, которая будет показывать на экран квадрат числа, введенного пользователем. Пользователь должен сам решать – выйти из программы или продолжить ввод. (Подсказка – необходимо запустить бесконечный цикл, в котором предусмотреть его прерывание, при наступлении определённого условия).

Показать код

2. В спортзал ежедневно приходит какое-то количество посетителей. Необходимо предложить пользователю ввести такие данные: сколько человек посетило спортзал за день, ввести возраст каждого посетителя и в итоге показать возраст самого старшего и самого молодого из них, а так же посчитать средний возраст посетителей.

Показать код

Для самостоятельно задания, предлагаем вам решить похожую задачу. Организовать ввод количества посетителей спортзала и количества часов проведенных каждым из них в спортзале. В итоге посчитать и показать общую сумму, которую посетители заплатили за тренировки.

3. На складе имеется определённое количество ящиков с яблоками (в нашем примере 15). Когда подъезжает машина для погрузки, попросить пользователя ввести, сколько ящиков загрузить в первую машину, во вторую и так далее, пока не закончатся ящики с яблоками. Предусмотреть тот случай, когда пользователь введёт количество ящиков больше, чем есть на складання

myudanova631
Var n,one,dec,hun,s: integer; begin writeln (' введи четырехзначное число'); readln (n); one: = n mod 10;                     ( находим цифру на месте единиц) dec: = ( n div 10) mod 10;               на   предпоследнем разряде hun: = ( n div 100) mod 10;           на третьем разряде с конца t: = n div 1000;                                 на первом разряде s: =one+dec+hun+t; if (s mod 2=0) or ( s mod 3=0 ) then writeln (' кратна 2 или 3)   else writeln (' не кратна'); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите самый простой вариант, без массивов с цикла! (первый год изучения паскаля) напишите программу, которая в последовательности целых чисел определяет разность максимального и минимального чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность) . количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: разность максимального и минимального чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgavlad199
Andrei_Mariya
fakelel
olgusikok
KosarinPotemkina1888
olga0909196323
pannotolstova488
ismailovi670771
Anatolii
Константин
westgti77105
balabinatanya7174
lukanaft
gennadevna
goryavinan