паскаль
откомпилирован в: pascal abc
program z1; uses crt; var s: string; c: char; i: integer; begin write(' vvedite strocy: '); readln(s); writeln(); write(' vvedite sivol dl poiska: '); readln(c); writeln(); for i : = 1 to length(s) do if s[i] = c then // begin writeln(' simvol prinadlech stroce = ', s); break; end; if s[i] < > c then writeln(' simvola net v stroke = ', s); end.
Поделитесь своими знаниями, ответьте на вопрос:
На питоне ! ! напишите программу, которая выводит последнее слово переданной её символьной строки. слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. входные данные входная строка содержит произвольную последовательность символов. выходные данные программа должна вывести последнее слово этой строки. примеры входные данные abra babra cadabra выходные данные cadabra
импликация — бинарная логическая связка, по своему применению приближенная к союзам «если… то…».
импликация записывается как посылкаследствие; применяются также стрелки другой формы и направленные в другую сторону (остриё всегда указывает на следствие).
суждение, выражаемое импликацией, выражается также следующими способами:
посылка является условием, достаточным для выполнения следствия; следствие является условием, необходимым для истинности посылки. x={"студент сдаст хорошо сессию"} y={"папа купит ему машину"}. однако, это не совсем удачная иллюстрация, потому что как-то не близка к действительности. напомню, что x-> y == 0 только в том случае, если студент действительно хорошо сдал сессию, а папа машину ему не купил (наоборот, если студент сдал плохо, а папа купил ему машину, то папу лжецом уж точно не назовёшь).