dannytr
?>

Составить программу вычисления площади круга и длину окружности величину радиуса вводить с клавиутуры , выход из программы при нулевом радиусе

Информатика

Ответы

МихайловнаLarisa1150

program z1;

var s,pi,l,r: real;

begin

pi: =3.14;

writeln('введите радиус');

readln(r);

if r=o then writeln('программа завершила работу') else

s: =pi*sqr(r);

l: =2*pi*r;

writeln('плащадь равна = ',s,'длина окр равна', l);

readln

end.

 

toniv

program dd; uses crt; var s,c,r,pi: real; beginwriteln('величина радиуса '); read(r); pi: =3.14; if r> 0 thenbegins: =pi*r*r; c: =2*pi*r; write ('площадь =',s: 6: 2,' длина окружности =',c: 6: 2) endelseend.

lenskiy
Изобразим с чертёжника треугольник, положение вершин которого на координатной плоскости определяется парами чисел  (1,,,2).  так как в начале работы перо чертёжника всегда поднято, то для рисования треугольника с заданными координатами достаточно выполнить следующую последовательность команд: переведи в точку  (1,1) опусти перо переведи в точку  (3,5) переведи в точку  (5,2) переведи в точку  (1,1).переведи в точку  (1,1) опусти перо переведи в точку  (1,3) переведи в точку  (5,3) переведи в точку  (5,1) переведи в точку  (1,1)
evge-borisova2
Сначала код без комментариев: var s: longint; i: integer; a: byte; begin s: =0; repeat     read(a);     if (a mod 2 < > 0)and(a mod 7 = 0) then s: =s+a; until a = 0; writeln('s = ',s); end. теперь объяснение каждой строки: var s: longint; i: integer; a: byte; // в эту переменную будет вводится число с клавиатуры. тип byte может принимать значения от 0 до 255. поэтому его как раз хватит. begin s: =0; // тут будет храниться сумма, поэтому переменную следует сперва обнулить. repeat // далее начинается цикл     read(a); // эта команда каждый раз считывает с клавы число, и записывает его в переменную a.     if (a mod 2 < > 0)and(a mod 7 = 0) then s: =s+a; //тут проверяется 2 условия, и если они выполняются - к переменной s прибавляется значение переменной а     1 условие: число нечётно, то есть остаток от деления его на 2 не равен нулю (a mod 2 < > 0)     2 условие: число кратно 7, то есть делится без остатка на 7, то есть остаток от деления равен нулю (a mod 7 = 0) until a = 0; // цикл повторяется до тех пор, пока введённое с клавы число не будет равно нулю (a = 0) writeln('s = ',s); // тут выводится искомая сумма end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления площади круга и длину окружности величину радиуса вводить с клавиутуры , выход из программы при нулевом радиусе
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

akbmaslafarkop3175
proplenkusale88
saltikovaPavlenko
mikhisakov2017
anatolevich1931
misspodvigina
tarhan1221
Стефаниди
pastore
Tochkamail370
Koranna1986
olimov
aa276568
Климова1317
armsam76