Liliya-buc
?>

16. составить программу для вывода двух массивов, первый из которых состоит из отрицательных элементов и задаётся вручную, второй- состоит из нечётных элементов и задаётся функцией случайного выбора. 20)составить массив из 10 отрицательных чисел. вывести второй массив, состоящий из элементов певого массива, умноженных на введенное число. все в тубропаскале: )

Информатика

Ответы

diana-kampoteks

1)

var

a,b: array [1..10] of integer;

i: integer;

begin

for i: =1 to 10 do begin

repeat 

write ('a[',i,'] = '); readln(a[i]);

if a[i]> 0 then writeln ('error! ');  

until a[i]< 0;  

end;

writeln ('first massiv: ');

for i: =1 to 10 do write (a[i]: 4);

writeln;  

writeln ('second massiv: ');

i: =1;  

repeat

b[i]: =random(38)+3;

if odd(b[i])=true then i: =i+1;  

until i> 10;

for i: =1 to 10 do write (b[i]: 4);

writeln;

readln;

end.

2)

var

a,b: array [1..10] of integer;

i,k: integer;

begin

randomize;

for i: =1 to 10 do begin

a[i]: =random(15)-15;

write (a[i]: 4);

end;

writeln;  

write ('number: '); readln(k);

for i: =1 to 10 do begin

b[i]: =a[i]*k;

write (b[i]: 4);

end;

writeln;

readln;

end.

kirillreznikov

ответ:

  class program

    {

        static void main(string[] args)

        {

            console.writeline("введите число a: ");

          int a = convert.toint32(console.;

            console.writeline("введите число b: ");

          int b = convert.toint32(console.;

            console.writeline("введите число c: ");

            int c = convert.toint32(console.; //вводим 3 числа

            int sredaref = a + b + c / 3; //считаем

            console.writeline("среднее арифметическое : " + sredaref); // выводим

            console.readkey();

        }

    }

объяснение:

Хохлова Иванович

ответ:

несколько примеров интерфейсов будущего.

для начала как видят дизайнеры и разработчики интерфейсы мобильных телефонов будущего.

mozilla searbird

empathy blackberry

amazing screen technology: samsung flexible amoled

как-то так сложилось, что образцом пользовательского интерфейса будущего в сми, в том числе и профессиональных, считается интерфейс, который использует герой тома круза в фильме «особое мнение» («minority report»).

«minority report»

далее иллюстрации с двух лекций с коференций ted, которые ссылаются на этот фильм. это «технология шестое чувство» пэтти мэес («sixth sense technology» pattie maes), профессора массачусетского технологического института, руководителя группы в лаборатории media lab, – интересная лекция, как нехитрый комплект стоимостью всего 350 долларов с программным обеспечением и доступом в интернет может сильно изменить нашу жизнь, в том числе заменив собой целый ряд бытовых предметов.

«sixth sense technology» pattie maes

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

16. составить программу для вывода двух массивов, первый из которых состоит из отрицательных элементов и задаётся вручную, второй- состоит из нечётных элементов и задаётся функцией случайного выбора. 20)составить массив из 10 отрицательных чисел. вывести второй массив, состоящий из элементов певого массива, умноженных на введенное число. все в тубропаскале: )
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

eugene869154
superkiosk249
notka19746
Sergei1805
olga0909196323
Evsevia-a
neblondinka19
ognevasv555
смирнов1127
tarasova
НатальяРуктешель472
Igorevich_Aleksandrovna1599
Tkachenko1050
seletan1
VolkovaMaslova