Написать программу которая в ответ на введенное с клавиатуры число выводит на экран сообщение о том положительное это число или отрицательное ( использовать оперытор )
if n< 0 then writeln ('число отрицательное') else writeln ('ноль');
readln;
end.
Тариелович871
24.10.2020
// pascalabc.net 3.2, сборка 1437 от 03.05.2017 // внимание! если программа не работает, обновите версию! begin var n: =readinteger('количество строк в массиве: '); var m: =readinteger('количество колонок в массиве: '); writeln('*** исходный массив [',n,',',m,'] ***'); var a: =matrrandom(n,m,-99,99); a.println(4); writeln(4*a.colcount*'-'); var s: =a.elementswithindexes.where(x-> x[2]< 0); writeln(s.count,' отрицательных элементов с суммой ',s.select(x-> x[2]).sum); writeln('*** результирующий массив ***'); foreach var ijv in s do a[ijv[0],ijv[1]]: =0; a.println(4) end. пример количество строк в массиве: 4 количество колонок в массиве: 7 *** исходный массив [4,7] *** 97 -4 -24 49 1 86 -15 -84 -17 -56 -76 -26 -77 49 -8 48 -29 60 20 82 90 -28 -4 -69 32 -63 -35 -72 17 отрицательных элементов с суммой -687 *** результирующий массив *** 97 0 0 49 1 86 0 0 0 0 0 0 0 49 0 48 0 60 20 82 90 0 0 0 32 0 0 0
lirene
24.10.2020
// pascalabc.net 3.2, сборка 1437 от 03.05.2017 // внимание! если программа не работает, обновите версию! function getdiagneganives(a: array[,] of integer): sequence of integer; begin for var i: =0 to a.rowcount-1 do if a[i,i]< 0 then yield(i) end; function getsumm(a: array[,] of integer; t: sequence of integer): integer; begin result: =0; foreach var e in t do result+=a.row(e).sum end; procedure matrixwrite(a: array[,] of integer); begin var n: =a.rowcount; writeln('*** исходная матрица [',n,',',n,'] ***'); a.println(4); writeln(4*a.colcount*'-') end; begin var n: =readinteger('количество строк/столбцов в матрице: '); var a: =matrrandom(n,n,-99,99); matrixwrite(a); var s: =getdiagneganives(a); writeln('s=',getsumm(a,s)) end. пример количество строк/столбцов в матрице: 5 *** исходная матрица [5,5] *** -31 -1 -29 -69 -19 -83 84 52 42 52 13 -24 -70 98 -33 60 -94 -84 19 -14 -55 81 -36 57 98 s=-165
program fom01;
uses crt;
var x: integer;
begin
writeln('введите число x');
readln(x);
if x> 0 then
writeln('положительное');
else
if x< 0 then
writeln('отрицательное');
readln;
end.