manager6
?>

Напишите программу, которая анализирует человека по возрасту и относит к одной из пяти групп: дошкольник, школьник, студент, работник, пенсионер.возраст вводится с клавиатуры.используйте оператор case.

Информатика

Ответы

zerckaln

пишем и объяснем. элемент case - это оператор аналогичный if, только условия более "скомпованы". для того, чтобы не вводить 10 раз if используют case. разбираем.

 

uses crt;

 

var n: real; //нужен только переменная возраста

 

begin

writeln('введите возраст человека'): read(n); //считываем возраст с клавиатуры

case n of:                                                                                               // таким образом объявляется этот оператор

0..6: writeln('дошкольник');                                                                 // пишим всякие числовые значения

7..18: writeln('школьник');                                                                     // которые можно менять.

18-24: writeln('студент');                                                                       //  технология

25-60: writeln('работник');                                                                   // аналогичная оператору if

60-100: wtiteln('пенсионер');                                              

      end;                       // обязательно end в конце - конец условия опертора

end.

 

 

olg53362928

var

  n: byte;

begin

  write ('vozrast: ');

  readln(n);

  case n of

    1..6: writeln ('дошкольник');

    7..18: writeln ('школьник');

    19..24: writeln ('студент');

    25..55: writeln ('работник');

    56..110: writeln ('пенсионер');  

    else writeln ('не факт,что доживет');

  end;

  readln;

end.

Спивак

var a: array[1..100,1..100]of integer;

n, m, i, j, mini, minj, maxi, maxj : integer;

 

begin

write('n, m -> ');

readln(n, m); {считываем размер матрицы}

write('input matrix -> ');

for i: =1 to n do for j: =1 to m do

begin

  write('a[',i,',',j,'] -> ');

  readln(a[i, j]);

end; {считываем саму матрицу}

readln;

mini: =1;

minj: =1;

maxi: =2;

maxj: =2;

for i: =1 to n do for j: =1 to m do if a[i,j] > a[maxi, maxj] then

begin

  maxi : = i;

  maxj : = j;

end else if a[i, j] < a[mini, minj] then

begin

  mini : = i;

  minj : = j;

end;

writeln('max = a[',maxi,',',maxj,'] = ', a[maxi, maxj]);

writeln('min = a[',mini,',',minj,'] = ', a[mini, minj]);

readln;

end.

novdodCT

program figyri;

uses crt,graphabc;

var xc,yc: integer;

    m: integer;

begin

xc: =windowwidth div 2;

yc: =windowheight div 2;

repeat

write ('введите число');

read (m);

if m> 2 then

    begin

      setpencolor(clgreen);

      rectangle(xc-100,yc-100,xc+100,yc+100);

      floodfill(xc,yc,clgreen);

      readkey;

    end;

if m< 2 then      

    begin

      setpencolor(clred);

      line (xc-100,yc+50,xc+100,yc+50);

      line (xc+100,yc+50,xc,yc-100);

      line(xc,yc-100,xc-100,yc+50);

      floodfill(xc,yc,clred);

      readkey;

    end;

if m mod 2=0 then

    begin

      setpencolor(clblue);

      circle (xc,yc,100);

      floodfill(xc,yc,clblue);

      readkey;

    end;

until not(m in [1..4]);

end.

как то так

если введенное число больше двух, то квадрат

если меньше, то треугольник

если кратно, то круг

можно выбрать по разному, будет ли введенное число больше или меньше какого то числа, будет ли оно положительным или отрицательным и т.д

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая анализирует человека по возрасту и относит к одной из пяти групп: дошкольник, школьник, студент, работник, пенсионер.возраст вводится с клавиатуры.используйте оператор case.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

srvsm
Nikishina
gub191025
yugraspets
fastprofit
Артур1807
optikmir
whiskyandcola
anastasiavilina
nadlen76
gk230650
rubanvladimir374
Виктория Нина
irina-mic
Алёна Геннадьевна98