webotryvclub21
?>

Составить программу на алгоритмическом языке с использованием арифметических выражений, найденных в учебнике

Информатика

Ответы

tata-novik
Кумиралг нач вещ firstnumber, secondnumber ввод firstnumber, secondnumber вывод "a + b = ", firstnumber + secondnumber, нс вывод "a - b = ", firstnumber - secondnumber, нс вывод "a * b = ", firstnumber * secondnumber, нс вывод "a / b = ", firstnumber / secondnumber, нс кон
Долбоебков_Алексей27
Var     i,j,pr: integer;     a: array[1..5,1..5] of integer; begin randomize; pr: =1; write('исходный массив: '); for i: =1 to 5 do     begin     writeln;     for j: =1 to 5 do       begin       a[i,j]: =random(4)+1;       write(a[i,j]: 2);       if i< j then pr: =pr*a[i,j]       end     end; writeln; writeln('произведение ',pr) end.
shneider1969
Розрізняють дві форми структури розгалуження: повну та неповну. Структура розгалуження повної форми схожа на умовне висловлювання «Якщо — то — інакше», у якому після «то» та «інакше» записують не висловлювання, а команди, які необхідно виконати залежно від істинності висловлювання, записаного в умові. Її можна подати графічно:
Ось приклад алгоритму із розгалуженням: написання слів із великої літери
Скорочену форму розгалуження використовують тоді, коли деяку по-слідовність команд слід виконати за умови істинності висловлювання.
Структура розгалуження неповної форми схожа на умовне висловлювання «Якщо — то», у якому після «то» записують не висловлювання, а послідовність команд, які необхідно виконати, коли висловлювання, записане в умові, є істинним. Її можна подати графічно
Наприклад, на малюнку подано графічну форму алгоритму застосування засобів автоматизованої перевірки правопису тексту, що складається зі слів, у середовищі текстового процесора Microsoft Word
Як описуються умови в алгоритмах із розгалуженням у середовищі Скретч?
Для опису алгоритмів із розгалуженням у середовищі Скретч можна використовувати блоки з групи Датчики. Ці блоки можуть бути складовими відповідних команд, що передбачають виконання певних дій після перевірки висловлювання на істинність чи хибність.
Складені умови, які використовують сполучники І, АБО, НЕ, у середовищі Скретч можна описати за до блоків
із групи Оператори. Наприклад, в алгоритмі в середовищі Скретч, виконавцем якого є Об'єкт І, умову «якщо Об’єкт 1 доторкається до Об’єкта 2 або доторкається межі вікна», можна подати в такому вигляді
Як у середовищі Скретч описати алгоритми з повним та неповним розгалуженням?
Базову структуру розгалуження повної форми в середовищі Скретч можна подати командою
Наприклад, алгоритм, за яким при натисненні клавіші Т на клавіатурі розмір об’єкта збільшується наполовину, інакше — зменшується на 10 %, можна подати графічно

або фрагментом програми в середовищі Скретч
Для реалізації розгалуження неповної форми в середовищі Скретч використовують команду, що зображена на малюнку
Наприклад, фрагмент алгоритму для середовища Скретч для малювання різнокольорової ламаної, за яким колір ліній буде змінюватися після натиснення кнопки миші, можна подати графічно
Цей фрагмент алгоритму для середовища Скретч можна описати так:
V. Практичне завдання. Інструктаж з техніки безпеки.
Учні займають місця біля комп’ютерів і виконують команди вчителя.
Завдання №1 (Вчитель демонструє складання даного проекту «Табличка множення») Створити проект, в якому було б реалізовано розв’язування такої задачі. Кіт вирішив з'ясувати, чи знаєте ви таблицю множення. Для цього він подасть приклад на множення чисел від 3 до 9 і перевірить вашу відповідь.
Релаксація «Вправи для очей» - Додаток А2
Завдання №2 Після створення та демонстрації учителем проекту «Завдання №1» учні самостійно створюють подібний проект. Зберегти проект під назвою «Табличка множення».
VI. Підсумок уроку. Узагальнення навчального матеріалу.
Скласти блок схему до задачі «Визначити агрегатний стан води (крига, рідина, пара) за її температурою».

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу на алгоритмическом языке с использованием арифметических выражений, найденных в учебнике
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

infocenterbla
Tatyana1426
yakovlevasvetlanalvovna209
MAXIM76748
Николаевич
Mark-Petrovich
Pavlov447
ilyagenius
danielianruz
lukanaft
oksana77768
svetlanam81
Olybetezina1973
timpavilion23
Староческуль-Станиславовна