krasnobaevdj3
?>

Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".

Информатика

Ответы

Puschdom
Ищем закономерности. год:   1, 21, 31, 41, 51, 61, 71, 81, 91, 101 (оканчивается  на  единицу,  исключение: 11 и 111) года: 2-4, 22-24, 32-34, 42-44, 52-54, 62-64, 72-74, 82-84, 92-94, 102-104 (оканчивается  на  2,  3  или  4,  исключения:   12,  13,  14,  112,  113,  114) лет: 0, 5-20, 25-30, 35-40, 45-50, 55-60, 65-70, 75-80, 85-90, 95-100, 105-120 (оканчивается  на  0,  5-9,  плюс исключения из  прошлых  пунктов) у исключений есть общее: остаток при делении  на  100  будет  в  промежутке  от  11  до  14. n -  возраст язык  программирования:   паскаль var n : integer  ; begin read (n) ; n : = n mod 100 ; if n in [11..14] then writeln ('лет'); else begin n  : =  n  mod  10  ; case n of 1 : writeln ('год') ; 2..4 :   writeln ('года')  ; 0,  5..9 : writeln ('лет')  ; end ; readln ; end.
mausgaly

pascalabc.net

function isprime(n: integer): boolean;   // простое?

begin

  if n < = 1 then

  begin

    result : = false;

    exit

  end;

  result : = true;

  var (j, r) : = (2, round(sqrt(;

  while result and (j < = r) do

    if n mod j = 0 then

    begin

      result : = false;

      exit

    end

    else

      j += 1;

end;

function ishyperprime(n: integer): boolean; // гиперпростое?

begin

  result : = false;

  var k : = 10;

  while n > 10 do

  begin

    n : = n div 10;  

    if not isprime(n) then exit

  end;  

  result : = true

end;

begin

  var (a, b) : = readinteger2;

  var found : = false;

  foreach var n in range(a, b) do

    if isprime(n) then // найдено простоe число

      if ishyperprime(n) then

      begin

        found : = true;

        n.print

      end;

  if not found then

    write(0)

end.

Gpack54

Объяснение:

Алгоритмы как логико-математические средства отражают различные компоненты человеческой деятельности и тенденции, а сами алгоритмы в зависимости от цели, начальных условий задачи, путей её решения, определения действий исполнителя классифицируются следующим образом [2]:

механические алгоритмы, называемые детерминированными, жёсткими (например, алгоритм работы двигателя), задают определённые действия, обозначая их в единственной и достоверной последовательности, обеспечивая тем самым однозначный требуемый результат, если выполняются те условия процесса, для которых разработан алгоритм;

гибкие алгоритмы:

вероятностные (стохастические) алгоритмы дают программу решения задачи несколькими путями или приводящими к вероятному достижению результата;

эвристические алгоритмы – это алгоритмы, в которых достижение конечного результата программы действий однозначно не предопределено, так же как не обозначена вся последовательность действий, не выявлены все действия исполнителя. К эвристическим алгоритмам относят, например, инструкции и предписания. В этих алгоритмах используются универсальные логические процедуры и принятия решений, основанные на аналогиях, ассоциациях и опыте решения схожих задач;

линейные алгоритмы – наборы команд, выполняемых последовательно во времени друг за другом;

разветвляющиеся алгоритмы – алгоритмы, содержащие хотя бы одно условие, в результате проверки которого ЭВМ обеспечивает переход на один из двух возможных шагов;

циклические алгоритмы – алгоритмы, предусматривающие многократное повторение одного и того же действия (или действий) над исходными данными. К циклическим алгоритмам сводится большинство методов вычислений, перебора вариантов;

вс алгоритмы (процедуры) – алгоритмы, ранее разработанные и целиком используемые при алгоритмизации конкретных задач.

Рассмотрим подробнее три основных вида алгоритмов: линейный, разветвляющийся и циклический.

Линейный алгоритм. Приведём пример записи алгоритма в виде блок-схемы, в виде программы на алгоритмическом языке и на языке Паскаль.

В качестве примера рассмотрим решение задачи вычисления среднего арифметического из двух чисел, вводимых с клавиатуры (рис. 1.2).



 

Разветвляющийся алгоритм. В качестве примера рассмотрим алгоритм нахождения максимального из двух чисел, введённых с клавиатуры (рис. 1.3).

 



Рис. 1.3. Пример разветвляющегося алгоритма

Циклический алгоритм. Работу циклического алгоритма рассмотрим на примере нахождения суммы чётных чисел, находящихся в диапазоне от 0 до n (n вводится с клавиатуры) (рис. 1.4).



Рис. 1.4. Пример циклического алгоритма

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая получает возраст человека от 0 до 120 лет и выводит со словом "год", "года", "лет".
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Абубакр_Будаш
alekbur
andrey4work918
ele922009226536
Виталий_Ильназ574
beliaevabeliaeva-olesya35
Aleksandr72
alexeytikhonov
Evelina Mariya
Belik-elena20111
Vasilevich
Viktorovich395
dmitrymakarov003
Yevgenevich
info36
▲