semenoffufc8
?>

Нужно сделать в паскале на столе лежит кучка монет. в этой кучке ровно n монет, каждая из которых имеет стоимость a[i]. можно выбрать только 3 монеты из кучки. ваша определить максимальную сумму, которую можно набрать? формат ввода: в первой строке находится число n - количество монет в кучке. далее следует n целых чисел a[i] - стоимость i-той монеты. 0 < = a[i] < = 10 3 < = n < = 10 формат вывода: одно число - ответ на .

Информатика

Ответы

andreyshulgin835
Программа написана на языке паскаль. uses crt; var m, n,t, i : integer; a : array [1..10] of integer; max : array [1..10] of integer; begin clrscr; m : = -100; write ('n =');   readln (n); for i: = 1 to n do  read (a[i]); for i: = 1 to n do if a[i]> =m then begin max[1]: = a[i]; m: =max[1];   end;   for i: = 1 to n do  if t< > 1 then if a[i]=max[1] then begin a[i]: =0; t: = t+1; end;     m: = -100; for i: = 1 to n do if a[i]> =m then begin max[2]: = a[i]; m: =max[2];   end;   t: = 0;   for i: = 1 to n do   if t< > 1 then if a[i]=max[2] then begin a[i]: =0; t: = t+1; end;     m: = -100; for i: = 1 to n do if a[i]> =m then begin max[3]: = a[i]; m: =max[3];   end;   t: = 0;   for i: = 1 to n do  if t< > 1 then if a[i]=max[3] then begin a[i]: =0; t: = t+1; end;   m: = -100;   writeln; for i : = 1 to 3 do t: = max[i]+t; writeln ('otvet ',t); readkey; end.
Шеина
Var a,b: real; begin readln(a,b);           if a> b then begin writeln('квадрат числа',a,'=',a*a);                                                     writeln('корень числа ',b,'=',sqrt(b));                                       end;           if b> a   then begin writeln('квадрат числа  ',b,'=',b*b);                                                     writeln('корень числа  ',a,'=',sqrt(a));                                       end;                     end.
ltdfoliant62
Var       a, b, c, d: real; begin       readln(a, b, c);       if a = 0 then begin               if b = 0 then                       writeln('х может быть любым')               else                       writeln('x = ', c / -b);               exit;       end;             d : = (b * b) - 4 * a * c;       if d < 0 then begin               writeln('комплексные корни');               exit;       end;             writeln('x1 = ', -b + sqrt(d) / (2 * a));       writeln('x2 = ', -b - sqrt(d) / (2 * a)); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно сделать в паскале на столе лежит кучка монет. в этой кучке ровно n монет, каждая из которых имеет стоимость a[i]. можно выбрать только 3 монеты из кучки. ваша определить максимальную сумму, которую можно набрать? формат ввода: в первой строке находится число n - количество монет в кучке. далее следует n целых чисел a[i] - стоимость i-той монеты. 0 < = a[i] < = 10 3 < = n < = 10 формат вывода: одно число - ответ на .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chuhnin195107364
shilinmikhaillg
Voronin-Albertovich
Lolira64
uvarovig
vnolenev
Liliya-buc
anovikovsr
tcmir
ekasatkina
betepah
antoska391
Ignateva737
alexseyzyablov
sn009