dimiff5
?>

Написать программу на авс.net паскале которая высчитывает произведение первых n-чисел ряда p=2/3*2/5*2/7*..*2/2i+1

Информатика

Ответы

S.V. Zhoraevna1677

ответ:

var i,n: integer;

p: =real;

begin

read(n);

p: =1.0;

for i: =1 to n do

begin

p: =p*2/(i+1);

end;

write (p);

end.

Yulechkaakulova1993
Var   a,r: real; begin   write('введите a и n: '); read(a,r);   if a=2*r then writeln('квадрат описан около окружности')   else writeln('квадрат не описан около окружности') end. ************************************************************************** var   n: char;   cm: string; begin   write('введите натуральное двухзначное число: '); readln(cm);   write('введите цифру от 0 до 9: '); readln(n);   if pos('3',cm)> 0 then writeln('в числе есть цифра 3')   else writeln('в числе нет цифры 3');   if (pos('6',cm)> 0) or (pos('7',cm)> 0) or (pos('9',cm)> 0)       then writeln('в числе есть цифра 6,7 или 9')       else writeln('в числе нет цифры 6,7 или 9');   if pos(n,cm)> 0 then writeln('в числе есть цифра ',n)   else writeln('в числе нет цифры ',n) end.
Yelena Kotova
Тебе нужно всё к двойке.  4 это 2 в квадрате, значит 2 в 510 + 2 в 255 - 2 в 8 (это будет 256, берем больше чтобы заполнить всё число, а теперь вычитаем то, что нам не надо) 2 в нулевой (будет 1, т.е 256-1=255) 2 в 510 + 2 в 255 - 2 в 8 +2 в 0 бывает так, что наши "квадраты" стоят не в порядке убывания, тогда расставляем их в порядке убывания. например если бы было 255 +510 -8 мы бы сделали 510+255-8 ну а теперь считаем единицы: первая цифра всегда считается как единица, минус мы считаем 255 - 8 = 247 единиц  и одна единица в конце 2в 0 итого получаем первое число всегда единица 1 + минус получился 247 + единица в конце +1     = 249

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на авс.net паскале которая высчитывает произведение первых n-чисел ряда p=2/3*2/5*2/7*..*2/2i+1
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bykovaam
sssashago8
marim1994361
ska67mto3983
artashhovhan
katyn76
aetolstih
Yelena642
ВадимСмирнов116
osipovasalex5316
YekaterinaAbinskov
snab54
Aleksei
agaltsova86
Попова1271