var N,st,dt,t,s,d,e:integer;
begin
writeln('Введите число');
readln(N);
st:= N div 100000;
dt:= N div 10000 mod 10;
t:= N div 1000 mod 10;
s:= N div 100 mod 10;
d:= N div 10 mod 10 ;
e:= N mod 10;
s:= st+dt+t+s+d+e;
print(s);
end.
Поделитесь своими знаниями, ответьте на вопрос:
Найдите сумму цифр натурального шестизначного числа. Составьте программу в паскаль
var N,st,dt,t,s,d,e:integer;
begin
writeln('Введите число');
readln(N);
st:= N div 100000;
dt:= N div 10000 mod 10;
t:= N div 1000 mod 10;
s:= N div 100 mod 10;
d:= N div 10 mod 10 ;
e:= N mod 10;
s:= st+dt+t+s+d+e;
print(s);
end.