Alekseevich_Viktorovna
?>

Составить программу-тренажер «устный счет от 10 до 100», предъявляющую пользователю поочередно примеры на проверку навыков устного счета и проверяющую правильность вычисления пользователем. программа должна выводить на экран произвольные два двузначных числа и знак «+» или «-» между ними. потом пользователь должен ввести свой ответ, а программа проверяет правильность вычислений.

Информатика

Ответы

Бисеров-Чистякова

ответ:

begin

a : =random(100);

b : =random(100);

if 50> random(100) then ch: ='+'

else ch: ='-';

write(a,ch,b);

read(o);

if (ch='+' and a+b=o) or (ch='-' and a-b=o) then write('ok')

else write('wrong');

end.

sde19755511
Итак зацикливание в программировании - это ситуация, когда цикл написан таким образом ,что условия выхода из него не выполняется. рассмотрим зацикливание в операторах цикла for,while и repeat . справедливости ради все варианты будут рассмотрены в turbo pascal и pascalabc. также будет добавлен оператор write для вывода результатов. зацикливание в for вообще идея зацикливания проста : необходимо всего-то в каждом шаге цикла уменьшать оператор шага на 1 (i: =i-1; ) . однако именно такая реализация возможна не везде. рассмотрим простой пример. for i: =1 to 5 do begin i: =i-1; write(i); end. казалось бы все просто,да не тут то было.в то время как в turbo pascal все проходит на ура,в pascalabc такое не возможно и для зацикливания необходимо использовать оператор goto. label m; var i: integer; begin m: for i: =1 to 5 do begin write(i); if i=2 then goto m; end; end. зацикливание в while напомню,что в операторе while шаг цикла необходимо добавлять самостоятельно. поэтому произвести зацикливание проще всего : нужно только убрать шаг цикла var i: integer; begin i: =0; while i< > 1 do write(i); end. оба компилятора адекватно реагируют на пропуск шага. зацикливание в repeat для создание бесконечного цикла в этом случае, как и предыдущем, достаточно не указывать шаг цикла var i: integer; begin i: =0; repeat write(i); until i=1; end. тут вам различные варианты для создание бесконечного цикла. однако запомните,что зацикливание создает нагрузку и вообще редко используется. гораздо чаще применяют неполное зацикливание при котором выход из цикла все же совершается.
gip5362
Как-то  так  var a,b,c,h,p,s: real; var ch: char; var f: boolean; begin repeat write('êàê ñ÷èòàåì ïëîùàäü? 1-ïî ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: '); readln(ch); if ch='1' then begin write('a='); read(a); write('b='); read(b); write('c='); read(c); p: =(a+b+c)/2; s: =sqrt(p*(p-a)*(p-b)*(p-c)); writeln('ïëîùàäü ðàâíà ',s); f: =true; end else if ch='2' then begin write('a='); read(a); write('h='); read(h); writeln('ïëîùàäü ðàâíà ',0.5*h*a); f: =true; end else begin cls; writeln('îòâåò ôèãîâûé! åùå ðàçîê: 1-ïî ãåðîíó, 2-÷åðåç ïîëîâèíó ïðîèçâåäåíèÿ îñíîâàíèÿ íà âûñîòó: '); end; until f; end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу-тренажер «устный счет от 10 до 100», предъявляющую пользователю поочередно примеры на проверку навыков устного счета и проверяющую правильность вычисления пользователем. программа должна выводить на экран произвольные два двузначных числа и знак «+» или «-» между ними. потом пользователь должен ввести свой ответ, а программа проверяет правильность вычислений.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dannytr
Виктория1690
goryavinan
ValerevnaRustam1072
korchags19983941
Emasterova77
expo3217
olesya-cat8601
av52nazarov
marinatehnomaster21
Ирина-Макаркина253
randat887040
lyukiss
Vladimir-Tamara1359
Serdechnaya636