Dmitriy793
?>

Составить программу нахождения произведения четных двузначных чисел, со всеми цикла.

Информатика

Ответы

yurick2071488
1) #include < iostream> using namespace std; int main() {   unsigned long long p = 1;   for (int i = 10; i< =98; i+=2)     p*=i;   cout < < "proizvedenie: " < < p < < endl;   return 0; } 2) #include < iostream> using namespace std; int main() {   unsigned long long p = 1;   int i = 10;   while (i< =98)   {     p*=i;     i+=2;   }   cout < < "proizvedenie: " < < p < < endl;   return 0; } 3) #include < iostream> using namespace std; int main() {   unsigned long long p = 1;   int i = 10;   do   {     p*=i;     i+=2;   }   while (i< =98);   cout < < "proizvedenie: " < < p < < endl;   return 0; } столь большое произведение не поместиться даже unsigned long long,поэтому результатом будет выдавать 0
Alekseevich_Elena

program zzz;

var

 max, k, a: integer;

 s: string;

begin

 assign(input, 'zad_24.txt');

 readln(s);

 a := 1;

 max := 1;

 for var i := 2 to length(s) do

   if (s[i] = s[i - 1]) and (s[i] = 'C') then

   begin

     k := k + 1;

     if max > i then

       max := i;

   end

   else

     max := 1;

 writeln(a);

end.

Объяснение:

Циклическую переменную i стоит использовать только в самом for, т. е. она выполняет функцию счетчика.

Я заменил переменную i вне цикла на переменную a.

Что касается ошибки "Параметр цикла for должен описываться в заголовке цикла" - for var i := 2 to length(s) do

Не нужно циклическую переменную указывать глобально в var

Стуканова УЧРЕЖДЕНИЕ1877
// pascalabc.net 3.3, сборка 1579 от 18.11.2017 // внимание! если программа не работает, обновите версию! begin   var (m,n): =readinteger2('количество строк и столбцов в матрице: ');   writeln('*** исходная матрица [',m,',',n,'] ***');   var a: =matrrandom(m,n,-50,50);   a.println(4); writeln(4*a.colcount*'-');   var s: =a.rows.selectmany(x-> x);   var max: =s.max;   writeln('максимум ',max, ' встречается ',           s.where(x-> x=max).count,' раз(а)') end. пример количество строк и столбцов в матрице: 6 11 *** исходная матрица [6,11] ***   15  19  26    0 -21 -42    8  -9  -7  21  19   -7 -49  23 -10    8  -9 -50 -31    8 -49 -36   -42 -45 -49 -11    3 -45 -20  45 -29  39  13     9  45 -19    9 -31 -38  29  27  39  13  36   -47  28  44    8 -22  28    7 -25  -3  -9  39     1  11  20  -1  40    5    2 -40  -2  -1  30 максимум 45 встречается 2 раз(а)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу нахождения произведения четных двузначных чисел, со всеми цикла.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

achernakov
alesia1986
KrisTinka
antilopa001
ilyagenius
punctvydachi
kuz-vlad21
alex13izmailov
katya860531
Anastasiya
Viktoromto
optikaleks7
annabanova9
borodin
Olga_Vyacheslavovich1054
▲